Last Comment Bug 781047 - [adbe 3306958] crash in F_773489510_____________________________________________
: [adbe 3306958] crash in F_773489510_____________________________________________
Status: RESOLVED FIXED
[flash-11.4]
: crash, reproducible, topcrash
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: 15 Branch
: x86 Windows 7
: -- critical (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: juan becerra [:juanb]
Mentors:
: 780658 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-07 16:53 PDT by juan becerra [:juanb]
Modified: 2012-08-27 13:53 PDT (History)
6 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description juan becerra [:juanb] 2012-08-07 16:53:21 PDT
This bug was filed from the Socorro interface and is 
report bp-6f4979ac-095b-4a0b-9cbf-b6c4d2120807 .
============================================================= 

Steps:
1. Using Flash 11.4.400.252, go to youtube.com and play a video like http://www.youtube.com/watch?v=ExdmX7QQ99M (N2 the Preppy Cat)
2. Click on the full screen video control
3. Let it play for a minute or so
4. Right click to bring up the context menu and choose "Pop Out"

Expected: Exit from full screen and an pop-out window that continues to play the video.

Actual: There's a full screen exit, and a pop-out window appears but Firefox hangs.

On a WinXP VM there's no way out of it, but quitting the app when it stops responding.

On a Win7 machine you get the above signature.
Comment 1 Robert Kaiser (not working on stability any more) 2012-08-08 07:03:18 PDT
This is probably a case of bug 780658 and we'll probably need to dupe that one against this one, esp. once the reprocessing in bug 781005 has been done.
Comment 2 Benjamin Smedberg [:bsmedberg] 2012-08-09 08:50:48 PDT
*** Bug 780658 has been marked as a duplicate of this bug. ***
Comment 3 Robert Kaiser (not working on stability any more) 2012-08-09 08:51:53 PDT
As https://crash-analysis.mozilla.com/rkaiser/2012-08-08/2012-08-08.firefox.flash.11-4-400-252.html shows, this accounts for ~60% of all crashes in this beta Flash version.
Comment 4 Benjamin Smedberg [:bsmedberg] 2012-08-09 08:54:15 PDT
Sal, can you make sure this is in bugbase and somebody's looking at it?
Comment 5 Jeromie Clark 2012-08-09 11:09:23 PDT
This is Adobe internal 3306958.  We're treating this as our highest priority issue.
Comment 6 Jeromie Clark 2012-08-09 12:13:57 PDT
We believe this is already fixed in Flash Player 11.4.400.257, which went out via background update last night.  I'll send an installer to Benjamin and Juan for confirmation.
Comment 7 Marcia Knous [:marcia - use ni] 2012-08-09 16:21:14 PDT
I have been testing this down in the lab on the same machine where I originally reprouduced the issue. Although I haven't yet reproduced with v .257, I have seen some odd behavior related to "popping out" on video on youtube.com as well as some browser freezes when I try to switch tabs. Right now I am working on trying to get a screencast of what I am seeing.

The issue I have with the pop out context menu on youtube.com is it does not work consistently on all videos.
Comment 8 juan becerra [:juanb] 2012-08-09 17:50:15 PDT
First, I went back to testing .252 on a WinXP and Win7 virtual machines, and I was able to reproduce the hang/crash respectively using Fx15b3. Then I tried .257 and I was able to reproduce the problem on WinXP, but I haven't been able to reproduce the problem on Win7.

A slight difference I noticed was that the context menu items didn't seem to be actionable for a little while when using the new version. On Win7 selecting the Pop Out item paused the video most of the times.

So this new version seems to prevent the crash at least on Win7.
Comment 9 Jeromie Clark 2012-08-09 18:58:57 PDT
We see a similar crash on WinXP, but the crash signature is different.  The Win7 crash was specific to ProtectedMode, and we're pretty confident that it's resolved.

Would you mind spinning up a new bug for the WinXP issue and providing some guidance on whether or not you consider that signature a stop-ship?
Comment 10 Jeromie Clark 2012-08-09 19:02:28 PDT
Quick correction, sorry.  We see a hang in WinXP but no crash.  We don't see the critical security impact that would warrant a stop-ship for XP.  If you guys disagree, please let me know so that I can surface it to my management for discussion.
Comment 11 Jeromie Clark 2012-08-09 19:39:32 PDT
@Marcia - we saw the same inconsistent behavior as well.  Context Menu is heinously difficult.  Our primary concern here is the crash, but we will want to further refine the context menu behavior in a future release.  

This one of those areas that would benefit greatly from a design meeting with Adobe and Mozilla.
Comment 12 Scoobidiver (away) 2012-08-18 15:19:35 PDT
It's #20 top crasher in 15.0b5, #31 in 16.0a2 and #47 in 17.0a1.
Comment 13 smadayag 2012-08-27 13:53:37 PDT
code change made in flash player 11.4, Dolores.  11.4.402.265 was released on 8/21.  closing.

Note You need to log in before you can comment on or make changes to this bug.