If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

kuma: preview changes: relative links broken

RESOLVED FIXED

Status

Mozilla Developer Network
Wiki pages
P2
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: allen.l.zhu, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64) AppleWebKit/537.2 (KHTML, like Gecko) Chrome/22.0.1216.0 Safari/537.2

Steps to reproduce:

1) Go to e.g. https://developer.mozilla.org/en-US/docs/WebGL/Using_shaders_to_apply_color_in_WebGL
1) Note that the "Next" link at bottom of page works.
2) Edit > Preview changes


Actual results:

"Next" link in preview points to https://developer.mozilla.org/undefined/docs/WebGL/Adding_2D_content_to_a_WebGL_context


Expected results:

"Next" link in preview points to https://developer.mozilla.org/en-US/docs/WebGL/Animating_objects_with_WebGL
Status: UNCONFIRMED → NEW
Ever confirmed: true
Looks as though the locale is missing.
Fix is to add "locale=request.locale," to the env_vars variable within "apps/wiki/kumascript"'s "post" method.

My machine is messed up a bit at the moment, so I can't test.  Luke?
Duplicate of this bug: 768631
Priority: -- → P2

Comment 4

5 years ago
Commits pushed to master at https://github.com/mozilla/kuma

https://github.com/mozilla/kuma/commit/8a02d28f33e22011591c6e09489cdd9ac2a2189b
fix bug 781063 - provide locale to the preview functionality

https://github.com/mozilla/kuma/commit/2a9f20a603c2e0a4e90d1280ee1591d7d48251ba
Merge pull request #587 from darkwing/preview-locale-781063

fix bug 781063 - provide locale to the preview functionality

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Component: Website → Landing pages
Product: Mozilla Developer Network → Mozilla Developer Network
You need to log in before you can comment on or make changes to this bug.