Last Comment Bug 781086 - horizontal scrollbar appears when not expected
: horizontal scrollbar appears when not expected
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla17
Assigned To: Timothy Nikkel (:tnikkel)
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks: 770453
  Show dependency treegraph
 
Reported: 2012-08-07 22:01 PDT by Timothy Nikkel (:tnikkel)
Modified: 2012-10-15 07:09 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified


Attachments
testcase (283 bytes, text/html)
2012-08-07 22:01 PDT, Timothy Nikkel (:tnikkel)
no flags Details
patch (1.27 KB, patch)
2012-08-13 14:35 PDT, Timothy Nikkel (:tnikkel)
roc: review+
Details | Diff | Splinter Review

Description Timothy Nikkel (:tnikkel) 2012-08-07 22:01:07 PDT
Created attachment 649963 [details]
testcase

Open the testcase, see horizontal scrollbar. We didn't use to have one. Might be Linux only.

The first bad revision is:
changeset:   101294:b5e444664a6c
user:        Markus Stange <mstange@themasta.com>
date:        Fri Aug 03 12:35:14 2012 +0200
summary:     Bug 770453 - [b2g] Semi-transparent scroll bars should not occupy content-flow space. r=roc
Comment 1 Timothy Nikkel (:tnikkel) 2012-08-13 14:35:10 PDT
Created attachment 651535 [details] [diff] [review]
patch

Looks like the argument was in the wrong spot accidentally, meaning we got the min size where it was intended for us to retrieve the pref size.
Comment 2 Timothy Nikkel (:tnikkel) 2012-08-13 20:00:37 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/d7f2c4c81804
Comment 3 Ed Morley [:emorley] 2012-08-14 05:59:42 PDT
https://hg.mozilla.org/mozilla-central/rev/d7f2c4c81804
Comment 4 Virgil Dicu [:virgil] [QA] 2012-10-15 07:09:34 PDT
Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/17.0 Firefox/17.0

Verified with Ubuntu Unity and XFCE (with the help of lcamacho). Firefox 17 beta1

Note You need to log in before you can comment on or make changes to this bug.