Last Comment Bug 781124 - Report CPU usage for hung Flash processes
: Report CPU usage for hung Flash processes
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: 17 Branch
: All Windows 7
: -- normal (vote)
: mozilla17
Assigned To: Georg Fritzsche [:gfritzsche]
:
Mentors:
Depends on: 764660
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-08 03:40 PDT by Georg Fritzsche [:gfritzsche]
Modified: 2012-08-21 19:10 PDT (History)
2 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add Flash process CPU usage reporting (1.84 KB, patch)
2012-08-08 08:57 PDT, Georg Fritzsche [:gfritzsche]
no flags Details | Diff | Splinter Review
Add Flash process CPU usage reporting (5.69 KB, patch)
2012-08-08 09:03 PDT, Georg Fritzsche [:gfritzsche]
benjamin: review+
Details | Diff | Splinter Review
Add Flash process CPU usage reporting (5.74 KB, patch)
2012-08-08 10:12 PDT, Georg Fritzsche [:gfritzsche]
no flags Details | Diff | Splinter Review
Add Flash process CPU usage reporting (5.81 KB, patch)
2012-08-08 23:05 PDT, Georg Fritzsche [:gfritzsche]
no flags Details | Diff | Splinter Review
Add Flash process CPU usage reporting (5.92 KB, patch)
2012-08-09 03:47 PDT, Georg Fritzsche [:gfritzsche]
benjamin: review+
Details | Diff | Splinter Review
Add Flash process CPU usage reporting (5.93 KB, patch)
2012-08-20 11:09 PDT, Georg Fritzsche [:gfritzsche]
no flags Details | Diff | Splinter Review

Description Georg Fritzsche [:gfritzsche] 2012-08-08 03:40:42 PDT
Followup to bug 764660. Collect & report CPU usage for the Flash processes too when Flash hung.
Comment 1 Georg Fritzsche [:gfritzsche] 2012-08-08 08:57:31 PDT
Created attachment 650152 [details] [diff] [review]
Add Flash process CPU usage reporting
Comment 2 Georg Fritzsche [:gfritzsche] 2012-08-08 09:03:05 PDT
Created attachment 650156 [details] [diff] [review]
Add Flash process CPU usage reporting

Accidentally uploaded the wrong patch.
Comment 3 Georg Fritzsche [:gfritzsche] 2012-08-08 10:12:20 PDT
Created attachment 650198 [details] [diff] [review]
Add Flash process CPU usage reporting

Added missing commit message.
Comment 4 Georg Fritzsche [:gfritzsche] 2012-08-08 10:13:29 PDT
Note: this patch is based on bug 781133.
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-08-08 12:08:36 PDT
This is bitrotted. Please rebase.
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-08-08 12:10:05 PDT
(In reply to Ryan VanderMeulen from comment #5)
> This is bitrotted. Please rebase.

Nevermind me.
Comment 7 Ryan VanderMeulen [:RyanVM] 2012-08-08 12:51:57 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/fccc68cc904f
Comment 8 Ryan VanderMeulen [:RyanVM] 2012-08-08 17:57:34 PDT
This was backed out due to causing Win64 build failures.
https://hg.mozilla.org/integration/mozilla-inbound/rev/40e59c86c2b3

https://tbpl.mozilla.org/php/getParsedLog.php?id=14237753&tree=Mozilla-Inbound

e:/builds/moz2_slave/m-in-w64/build/dom/plugins/ipc/PluginModuleParent.cpp(317) : error C2065: 'mFlashProcess1' : undeclared identifier

e:/builds/moz2_slave/m-in-w64/build/dom/plugins/ipc/PluginModuleParent.cpp(317) : error C2065: 'mFlashProcess1' : undeclared identifier

e:/builds/moz2_slave/m-in-w64/build/dom/plugins/ipc/PluginModuleParent.cpp(320) : error C2065: 'mFlashProcess2' : undeclared identifier

e:/builds/moz2_slave/m-in-w64/build/dom/plugins/ipc/PluginModuleParent.cpp(320) : error C2065: 'mFlashProcess2' : undeclared identifier
Comment 9 Georg Fritzsche [:gfritzsche] 2012-08-08 23:05:03 PDT
Created attachment 650447 [details] [diff] [review]
Add Flash process CPU usage reporting

Fix missing "#ifdef MOZ_CRASHREPORTER_INJECTOR".

Pushed to try: https://tbpl.mozilla.org/?tree=Try&rev=86efe3cba06a
Comment 10 Georg Fritzsche [:gfritzsche] 2012-08-09 03:47:08 PDT
Created attachment 650496 [details] [diff] [review]
Add Flash process CPU usage reporting

* Rebased on patch 781133, attachment 650475 [details] [diff] [review]
* Fixed remaining issues
* Try: https://tbpl.mozilla.org/?tree=Try&rev=16ff9fd62753

I wonder how i even got this through my local tests yesterday.
Comment 11 Georg Fritzsche [:gfritzsche] 2012-08-09 08:24:40 PDT
Comment on attachment 650496 [details] [diff] [review]
Add Flash process CPU usage reporting

Try build results are fine. Benjamin, can you do a follow review?
Comment 12 Georg Fritzsche [:gfritzsche] 2012-08-20 11:09:04 PDT
Created attachment 653440 [details] [diff] [review]
Add Flash process CPU usage reporting

Rebased on patch for bug 781133
Comment 13 Georg Fritzsche [:gfritzsche] 2012-08-20 11:10:44 PDT
Checkin note: This is based on patch 653426 on bug 781133.
Comment 14 Ryan VanderMeulen [:RyanVM] 2012-08-21 03:38:23 PDT
Green on Try (the Android R2 failure is unrelated).
https://tbpl.mozilla.org/?tree=Try&rev=cfba471376c9

https://hg.mozilla.org/integration/mozilla-inbound/rev/4c81cb568cb4
Comment 15 Ryan VanderMeulen [:RyanVM] 2012-08-21 19:10:46 PDT
https://hg.mozilla.org/mozilla-central/rev/4c81cb568cb4

Note You need to log in before you can comment on or make changes to this bug.