mail window does not honor state of "use system colors" checkbox anymore

VERIFIED DUPLICATE of bug 77828

Status

SeaMonkey
MailNews: Message Display
--
major
VERIFIED DUPLICATE of bug 77828
17 years ago
14 years ago

People

(Reporter: Brian Tarricone, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.3 i686; en-US; rv:0.8.1+) Gecko/20010429
BuildID:    2001042906

the "use system colors" checkbox in the color preferences is broken in that
deselecting the checkbox does not cause the mail window to use the colors
specified by the color picker above the checkbox.

i've noticed this occurring in the builds of the past few days.  i'm not
entirely sure, but i think builds of more than 3-4 days ago did not have this
problem.  either that, or the color handling of the theme i'm (BHgtk) using
worked before and broke several days ago.

Reproducible: Always
Steps to Reproduce:
1. open prefs, colors section
2. deselect "use system colors," set reasonable fore/background colors
3. open messenger
4. click on a mail message

Actual Results:  no matter what the colors are se to in prefs, all selected mail
messages display with white text on a white background

Expected Results:  followed my selected colors - i.e. display black text on a
white background

this _may_ be related to GTK and the current theme i am using.  colors appear
fine on other themes.  _this_ part is related to bug 67448 ("GTK system colors
don't reflect reality").  the main problem here is that deselecting the "use
system colors" checkbox is NOT allowing the user to override the system colors
like it should.

Comment 1

17 years ago
that's bug 77828

*** This bug has been marked as a duplicate of 77828 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
verified dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.