If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Wrong png-color interpretation on Linux (color managment problem)

RESOLVED DUPLICATE of bug 621474

Status

()

Core
GFX: Color Management
RESOLVED DUPLICATE of bug 621474
5 years ago
3 years ago

People

(Reporter: Daniel-Knobe, Assigned: Glenn Randers-Pehrson)

Tracking

14 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 650089 [details]
bug.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713224749

Steps to reproduce:

Opened the page: http://blobby.sf.net on an Ubuntu 12.04 with Firefox 14.0.1


Actual results:

The drawing of http://blobby.sf.net/img/bg.img is not correct. The colors are wrong. If you download the actual image bg.png and compare it with the drawing of the http://blobby.sf.net page the colors are different. See attachment.



Expected results:

Same colors on page http://blobby.sf.net and the actual image http://blobby.sf.net/img/bg.img.
What happens if you set gfx.color_management.mode to false in about:config
http://blobby.sf.net/img/bg.img is a 404
(Reporter)

Comment 2

5 years ago
I'm sorry the right url is http://blobby.sf.net/img/bg.png .
(Reporter)

Comment 3

5 years ago
It is an integer so i set it to 0. Than everything works fine:). Thank you! But I think its a bug anyway.
0 is right, that disables the color management.
It's either a bug in the embedded color profile or your system/graphic card driver if disabling the color management makes it work
Component: Untriaged → GFX: Color Management
Product: Firefox → Core
(Reporter)

Comment 5

5 years ago
lspci says I have an IntelGM965 graphic card.
(Reporter)

Updated

5 years ago
Summary: Wrong png-color interpretation on Linux → Wrong png-color interpretation on Linux (color managment problem)
(Assignee)

Comment 6

5 years ago
Looks like a dupe of bug #621474
(Assignee)

Comment 7

5 years ago
Looks like a dupe of bug #621474.  PNG images marked with the sRGB tag (such as this "bg.png") are rendered as sRGB while HTML colors are rendered as gamma=1/2.2 which is a close approximation but not exactly sRGB.  When you display both on the same page, a faint difference is observable.
Assignee: nobody → glennrp+bmo
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 621474
You need to log in before you can comment on or make changes to this bug.