Page takes 4x as long to load as NS 4.7

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
18 years ago
15 years ago

People

(Reporter: bischoff, Assigned: attinasi)

Tracking

({perf})

Trunk
mozilla1.2alpha
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bae:20011126], URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.8.1+)
Gecko/20010429
BuildID:    2001042908

This page loads fine in IE 5.5, Mozilla, and Netscape 4.7. However, Mozilla
takes 4x as long as Netscape 4.7.

Reproducible: Always
Steps to Reproduce:
1. Load the page in Mozilla
2. Load the page in Netscape 4.7
3. Load the page in IE

Actual Results:  I timed the load-times on my stopwatch:

Mozilla 2001042908:    41.09 seconds    (the status bar confirms this)
Netscape 4.7:          10.92 seconds
IE 5.5:                 6.56 seconds

Expected Results:  Mozilla should be *at least* as fast as Netscape 4.7,
hopefully as fast as IE as well. 

This is on an Athlon 728 MHz on Win2k w/ 512 MB RAM, if that helps.
(Reporter)

Comment 1

18 years ago
Added perf keyword.
Keywords: perf

Comment 2

18 years ago
Also seeing this with 2001042908 / Win98SE and K6-2/300, 64 MB RAM and ISDN 8
KB/s dialup connection.

My numbers:
Netscape 4.77 : 15 sec.
Mozilla       : 52 sec.

Comment 3

18 years ago
yes...  mozilla is slower  ...  but not 4X  ...it is slower 2x 
-> layout. the site includes around 6 different external javascript files, 
Assignee: asa → karnaze
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout
Ever confirmed: true
QA Contact: doronr → petersen
(Reporter)

Comment 5

18 years ago
The recent builds seem to have improved the situation a bit. As of today's build
(2001050304), Mozilla takes 18.50 seconds for me (Athlon 728 MHz, 512 MB RAM).
It's still about 2x slower than Netscape 4.7, but it's getting better.

Comment 6

17 years ago
not table specific, reassigning to core owner.
Assignee: karnaze → attinasi

Comment 7

17 years ago
using the build from 20011126 build on win98, the timing was 14 seconds to load. 
Using the Netscape® Communicator 4.76 build, it took 13 seconds to load. 
Reporter, can you try this again?
Whiteboard: [bae:20011126]
Target Milestone: --- → mozilla1.2
No response from reporter in almost 2 yrs.; no noticable pageload problems
observed. Resolving WFM.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.