Last Comment Bug 781195 - If page does not exist, inform user before prompting for login
: If page does not exist, inform user before prompting for login
Status: RESOLVED FIXED
:
Product: Mozilla Developer Network
Classification: Other
Component: Editing (show other bugs)
: unspecified
: All All
: P2 normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 820442 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-08 08:18 PDT by Janet Swisher
Modified: 2013-11-11 18:27 PST (History)
1 user (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Janet Swisher 2012-08-08 08:18:45 PDT
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:15.0) Gecko/20100101 Firefox/15.0
Build ID: 20120724191344

Steps to reproduce:

While not logged in, I tried to navigate to a page that does not exist.


Actual results:

I got the Persona sign-in page, with no indication of why I was being asked to log in. (In MindTouch, I would have been bounced to the main page, so this is a HUGE improvement.)


Expected results:

I should get a page that says "The page you are trying to access does not exist. Do you want to create it?"

If Yes, prompt for login. If No, send them back to their previous page, if there is one; stay on that page if there is no previous one.
Comment 1 David Walsh :davidwalsh 2012-09-13 08:30:25 PDT
Great idea Janet!  This would probably curb a ton of confusion!
Comment 2 Janet Swisher 2012-09-13 10:02:52 PDT
Or, if No, give them a search box.
Comment 3 John Karahalis [:openjck] 2012-12-12 13:27:40 PST
*** Bug 820442 has been marked as a duplicate of this bug. ***
Comment 4 John Karahalis [:openjck] 2012-12-12 13:28:04 PST
I came across a user who was confused about this recently. See bug 820442.
Comment 5 Janet Swisher 2013-06-10 17:57:04 PDT
Following the steps above now gives a 404 page, including the text:

"If you were following a documentation link, you can sign in and create the page."

So, I'm closing this bug.

We did recently have a user create a page in order to tell us that the page did not exist. But that's a different problem for a different bug.

Note You need to log in before you can comment on or make changes to this bug.