Zimbra mail doesn't show all of my Yammer summary email

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: dhylands, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 650148 [details]
Screenshot showing scrollbar at 100% but not the bottom of the email

I'm running Nightly 17.0a1 (2012-08-07).

I'm running Linux Mint 13 (based on ubuntu 12.04).

I view my emails in Zimbra mail, and have a 3-pane setup (folders on left, email list on top and a preview pane on the bottom).

Every day, I receive a "Mozilla on Yammer" email. I can only read a portion of this email in Nightly. It won't let me scroll all of the way to the bottom.

If I resize my preview pane, it will allow me to see more or less.

Viewing the same thing in Chrome, I can see the entire contents of the message.
Does the mail set a fixed height on the <html> or <body> or something?

It's really hard to do anything with just the screenshot without having any idea what the CSS in the mail looks like.
(Reporter)

Comment 2

6 years ago
Created attachment 650193 [details]
HTML from page in question

I've attached the output of Right-clicking in the preview pane and selecting "View Page Source"
That's the source of the Zimbra UI itself, not of the mail in question...

Is that mail in an iframe?  Was there a "view frame source" option in the context menu?
(Reporter)

Comment 4

6 years ago
Created attachment 650200 [details]
Frame Source

Sorry - yes there was a frame menu. So this is the frame source.
Hmm.  Nothing there jumps out at me.  :(

If you save the zimbra page involved as "Web Page, complete" and then load the resulting saved page, does that still show the problem?  I'm guessing it'll just be completely broken after saving, but worth checking...
Another thing to try is bouncing that email to my @mozilla.com adress to see if I can reproduce after that...  Presumably I can't actually sign up for getting it myself without creating a Yammer account, right?
Dave, do you have Zimbra set to load the images in that mail by default?  Mine seem to be not set do do that, and I can reproduce the issue when images are not loaded, but the problem goes away when I tell it to load the images once.  Not sure yet whether that's because something different happens when the images are loaded or because the act of loading them changes things, hence the question about what your setup looks like.
I have the same problem with cut-off emails; I have Zimbra set to not load images by default.
Does it work right for you if you change that setting?
No, the same results with the images set to load by default.  Even after ticking the checkbox and force-reloading the UI.
(Reporter)

Comment 11

6 years ago
Mine was set to not load images by default. But after changing it the original email I received is still truncated. However the cc of the one I forwarded to Boris shows up fine (when load images is set). Both emails are truncated when image preload is not set.
Aha.

OK, I can try to figure out what the forward is doing, but it might be different from the original mail...  Alright, then.
I'm sorry; this totally got lost in the backlog.  :(  Before I start digging again, is this still being a problem?
Flags: needinfo?(dhylands)
(Reporter)

Comment 14

5 years ago
I haven't noticed the problem in recent Firefox (I just checked and the version on the computer I'm at right now is version 25)
Flags: needinfo?(dhylands)
OK.  Please reopen if it comes back?
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.