Test failure 'Disconnect Error: Application unexpectedly closed' in /testFlash_SWFVideoEmbed/test1.js

RESOLVED WORKSFORME

Status

P1
critical
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

unspecified
x86
Linux

Firefox Tracking Flags

(firefox15 affected, firefox16 affected, firefox17 unaffected)

Details

(Whiteboard: [mozmill-test-failure], URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
This is a fairly new regression. It only happens on Linux 32bit with the fr locale. 

Alex or Vlad, can someone please take this?
This seems to be failing on Beta on en-us as well:
http://mozmill-ci.blargon7.com/#/endurance/report/3491a2617d5af3ec9bb5c88aee0af740
I've tried to reproduce today on my local machine, but can't, all though I've tried on both Aurora fr and Beta en-us.
My Ubuntu is 11.04 though and maybe that counts, so I'm going to try again tomorrow with a clean Ubuntu 11.10
(Reporter)

Comment 2

6 years ago
(In reply to Alex Lakatos[:AlexLakatos] from comment #1)
> This seems to be failing on Beta on en-us as well:

I wonder if this could be a regression in Beta and already fixed in Nightly. Let me re-trigger a former 14.0 release testrun so we can check that. Test results should be up in a bit on mozmill-crowd. Please check when you come online.

> My Ubuntu is 11.04 though and maybe that counts, so I'm going to try again
> tomorrow with a clean Ubuntu 11.10

You should really upgrade to 12.04.
Assignee: nobody → alex.lakatos
Status: NEW → ASSIGNED
status-firefox15: --- → affected
status-firefox16: --- → affected
status-firefox17: --- → unaffected
(In reply to Henrik Skupin (:whimboo) from comment #2)
> (In reply to Alex Lakatos[:AlexLakatos] from comment #1)
> > This seems to be failing on Beta on en-us as well:
> 
> I wonder if this could be a regression in Beta and already fixed in Nightly.
> Let me re-trigger a former 14.0 release testrun so we can check that. Test
> results should be up in a bit on mozmill-crowd. Please check when you come
> online.
There seems they were not submitted, I can't see the report in Crowd.
> 
> > My Ubuntu is 11.04 though and maybe that counts, so I'm going to try again
> > tomorrow with a clean Ubuntu 11.10
> 
> You should really upgrade to 12.04.
Can't reproduce on 11.10, where it was reported, nor on 12.04.
(Reporter)

Comment 4

6 years ago
(In reply to Alex Lakatos[:AlexLakatos] from comment #3)
> > Let me re-trigger a former 14.0 release testrun so we can check that. Test
> > results should be up in a bit on mozmill-crowd. Please check when you come
> > online.
> There seems they were not submitted, I can't see the report in Crowd.

Huh? Both are there and only the fr one failed:

http://mozmill-crowd.blargon7.com/#/endurance/report/d87d47fd1034f072b9bece6ee6047fca

http://mozmill-crowd.blargon7.com/#/endurance/report/d87d47fd1034f072b9bece6ee6044f60

> Can't reproduce on 11.10, where it was reported, nor on 12.04.

Then we should use the CI system when we need more information. What would you propose as the next steps?
(Reporter)

Updated

6 years ago
Priority: -- → P1
It looks like this is at least occurring consistently on the CI for Ubuntu 11.10 since August 7th. I would suggest kicking off a test and watching the VM to see what the state of the application is at the point of failure.
(Reporter)

Comment 6

6 years ago
Failure for en-US locale:
http://mozmill-ci.blargon7.com/#/endurance/report/d87d47fd1034f072b9bece6ee63876a6

(In reply to Dave Hunt (:davehunt) from comment #5)
> 11.10 since August 7th. I would suggest kicking off a test and watching the
> VM to see what the state of the application is at the point of failure.

Dave, would you mind doing this?
I just watched a testrun of a previously failing build and it passed. Also, the daily testruns for today didn't show this failure either.
(Reporter)

Comment 8

6 years ago
I would say run a couple of testruns for affected builds in a sequence and watch todays testruns on that machine. Sadly we do not have the start time of this test so we could compare it with the end time of the testrun. :/
I've just run this again, and Firefox did appear to hang a couple of times. Unfortunately a test started running on the host so I had to interact to bring the Firefox window to the top. Looking at a report with a failure, it appears that the final iteration of the last successful test is at 03:04:59, and the testrun ended at 03:06:19. This means that the failing test ran for up to 1:20.
Created attachment 653847 [details]
Screenshot

I saw the hang again, and this time was able to grab a screenshot. I have also determined that simply moving the mouse cursor over the content area allowed the test to resume.
(Reporter)

Comment 11

6 years ago
Dave, would you mind to put a couple of dumb statements into the test code so we can get the information where in the test the hang happens?
(Reporter)

Comment 12

6 years ago
Any update on this one? I haven't seen it for a while.
We should get this additional detail once bug 786258 has landed.
Depends on: 786258
(Reporter)

Updated

6 years ago
Assignee: alex.lakatos.dev → nobody
Status: ASSIGNED → NEW
This is working properly now, I think it's safe to close.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.