If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Enable StrictMode's red screen flashing on unofficial builds

RESOLVED WONTFIX

Status

()

Firefox for Android
General
P3
normal
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: cpeterson, Assigned: cpeterson)

Tracking

(Depends on: 1 bug)

Trunk
Firefox 17
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 650215 [details] [diff] [review]
enable-StrictMode-penaltyFlashScreen.patch

Starting with Honeycomb, StrictMode can flash a red rectangle to warn violations: 

  http://developer.android.com/reference/android/os/StrictMode.ThreadPolicy.Builder.html#penaltyFlashScreen%28%29

More annoying warning options include crashing or a (non-fatal) dialog box. But I think these are too aggressive.

We currently enable StrictMode in unofficial builds: local, Nightly, and Aurora.
Attachment #650215 - Flags: review?(blassey.bugs)
(Assignee)

Updated

5 years ago
Depends on: 781249
Attachment #650215 - Flags: review?(blassey.bugs) → review+
(Assignee)

Comment 1

5 years ago
Green tryserver run:
https://tbpl.mozilla.org/?tree=Try&rev=6db4694cc2bf
(Assignee)

Comment 2

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/a1c1113cdf3e

Comment 3

5 years ago
https://hg.mozilla.org/mozilla-central/rev/a1c1113cdf3e
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
status-firefox17: --- → fixed
(Assignee)

Comment 4

5 years ago
Comment on attachment 650215 [details] [diff] [review]
enable-StrictMode-penaltyFlashScreen.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): N/A
User impact if declined: None. This is a debugging feature that only activates itself in Nightly and Aurora builds.
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): Low risk. This debugging feature already exists; my patch just tweaks how it works on Android >= Honeycomb.
String or UUID changes made by this patch: N/A
Attachment #650215 - Flags: approval-mozilla-aurora?
Attachment #650215 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 5

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/a7e88d150acb
status-firefox15: --- → wontfix
status-firefox16: --- → fixed
(Assignee)

Comment 6

5 years ago
I backed out of m-a because, after some discussion, I think this will cause more user confusion than it's worth.
https://hg.mozilla.org/releases/mozilla-aurora/rev/2129954bde52
status-firefox15: wontfix → ---
status-firefox16: fixed → ---
(Assignee)

Comment 7

5 years ago
I backed out of m-c, too.
https://hg.mozilla.org/mozilla-central/rev/16932b475002
status-firefox17: fixed → ---
Resolution: FIXED → WONTFIX
(Assignee)

Updated

5 years ago
Blocks: 783166
You need to log in before you can comment on or make changes to this bug.