Nigthly, Plugin-Container continues to run after closing a tab. Example would be a youtube video, closing while streaming causes it to continue until end of video Started happening after updating Nightly..

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Kyle, Unassigned)

Tracking

17 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20120808040204

Steps to reproduce:

Updated Nightly to new version; played a Youtube video, and upon changing tabs or closing it, plugin-container would continue to stream and/or play the video. This can be a potential bandwidth waster.


Actual results:

Plugin-container continued to stream videos after closing or leaving the webpage, and continues to stream after closing Firefox.


Expected results:

All media should halt immediately after leaving/closing the webpage; especially when the browser window is closed. I've recently changed my profile, I'd hate to have to do it again, and I have a feeling it's going to be patched within hours like usual.

Comment 1

6 years ago
Is it reproducible with a new Firefox profile (https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles) with the latest Nightly?

And are you running Flash 11.3?
(Reporter)

Comment 2

6 years ago
When I created a new profile, I didn't know how to just tranfer addons and other data, so I just copied the entire folder to it. I created the profile a few weeks ago though. I am running the most up to date Flash player, but I am using 64bit Nightly if that matters. The only way I can end the constant streaming and playing of video when the tab is closed is killing plugin-container manually through task manager. I'm not sure if it's safe to do so, but it works. The only way to prevent this in my case is to pause the video or wait until it ends so it won't continue to play.

Comment 3

6 years ago
You don't need to transfer your data and add-ons into the the new profile, the interest is to have a new fresh profile without add-ons and prefs changed.
Just create a new profile and start to reproduce your issue with a YT video.
This testing profile can be erased after your tests, it doesn't matter.
(Reporter)

Comment 4

6 years ago
(In reply to Loic from comment #3)
> You don't need to transfer your data and add-ons into the the new profile,
> the interest is to have a new fresh profile without add-ons and prefs
> changed.
> Just create a new profile and start to reproduce your issue with a YT video.
> This testing profile can be erased after your tests, it doesn't matter.

I found exactly what was wrong with it. The Greasemonkey userscript, Yousabletube fix was causing the problem and removing it fixed it. Sucks though, because it made everything a whole lot easier, setting it to enlarge the video and set to HD automatically. Thank you though, with your help I found out what it was.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.