Last Comment Bug 781398 - [b2g-bluetooth] Wrong connection used on thread for GetDeviceServiceChannelInternal
: [b2g-bluetooth] Wrong connection used on thread for GetDeviceServiceChannelIn...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla17
Assigned To: Eric Chou [:ericchou] [:echou]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-08 17:54 PDT by Kyle Machulis [:kmachulis] [:qdot]
Modified: 2012-08-09 15:01 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Final: patch 1: Replace mConnection with gThreadConnection, r=qDot (1.10 KB, patch)
2012-08-08 19:46 PDT, Eric Chou [:ericchou] [:echou]
kyle: review+
Details | Diff | Review

Description Kyle Machulis [:kmachulis] [:qdot] 2012-08-08 17:54:40 PDT
BluetoothDBusService::GetDeviceServiceChannelInternal uses mConnection, but asserts that it's not on the main thread. However, mConnection should never be used outside of the main thread. Since Bug 768306 has landed, this should use gThreadConnection.
Comment 1 Eric Chou [:ericchou] [:echou] 2012-08-08 19:46:00 PDT
Created attachment 650424 [details] [diff] [review]
Final: patch 1: Replace mConnection with gThreadConnection, r=qDot
Comment 2 Eric Chou [:ericchou] [:echou] 2012-08-09 08:16:33 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/f0929c40e255
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-08-09 15:01:36 PDT
https://hg.mozilla.org/mozilla-central/rev/f0929c40e255

Note You need to log in before you can comment on or make changes to this bug.