events in today pane could be one-liners

RESOLVED FIXED in 2.8

Status

--
enhancement
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: hm, Assigned: Taraman)

Tracking

Dependency tree / graph

Details

Attachments

(2 attachments, 4 obsolete attachments)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; FreeBSD i386; rv:14.0) Gecko/20120805 Firefox/14.0.1 SeaMonkey/2.11
Build ID: 20120805074345

Steps to reproduce:

by default my events in today pane show up as two-liners under date line



Expected results:

you could consider for better readability and having more events on screen, changing this behavior into showing events as one-liner, similar to task list
(Assignee)

Comment 1

5 years ago
That is a valid proposal.

Since I don't know why it was done like it is now, setting uiwanted to get it discussed.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Component: General → Calendar Views
Ever confirmed: true
Keywords: uiwanted
Version: Lightning 1.6 → Trunk
Probably to make it easier in the "Soon" section, because here you will need the full date, which will take up the whole line.

Ideally, we could make the boxes wrap automatically so that if the time/title is short enough it would fit on one line, otherwise it would wrap into two.

I don't know how easy that is to manage with XUL though.
(Assignee)

Comment 3

5 years ago
The Today pane utilizes the agenda-richlist for the display.
At the moment, it is the only place where the agenda is used.

Are there any thoughts of adding an "agenda-view" in the future? Then we should keep in Mind that the same code would also apply to this view.

I'll have a look, if the auto-wrap can be done though.
(Assignee)

Updated

5 years ago
Assignee: nobody → Mozilla
(Assignee)

Comment 4

5 years ago
Created attachment 766667 [details] [diff] [review]
Proposal for more compact Today-pane agenda

Since Philipp guessed it right and automatic wrap with XUL would mean a lot of workaround - if really achievable, I tried a different approach.

for items on "today" and "tomorrow", only the duration box is used and the titlebox is hidden.
For the soon-section with long dates, we get a 2-line display as is now.

Why?:
- Long titles are also cut off with current Lightnig. This solution will only crop 7 more characters. 
- normally you will have a good idea whats happening the next days, so you will know the event even with the title cut off.
- If we get an agenda-view sometime, it will be wider and this design will go well with that.
Attachment #766667 - Flags: review?(philipp)
Status: NEW → ASSIGNED
Created attachment 766923 [details] [diff] [review]
wrap text - v1

I just hacked this together shortly because Ms2ger asked about it. This breaks the allday event boxes and causes the allday area to scroll, but it would at least allow wrapping the text somehow. Maybe some special casing could be done for the allday items or the other way around for agenda items by using css -moz-box-flex instead of the flex attribute.

Maybe you can continue on this patch? If it doesn't work out we can still go with the other solution.
Attachment #766923 - Flags: feedback?(Mozilla)
(Assignee)

Comment 6

5 years ago
Comment on attachment 766923 [details] [diff] [review]
wrap text - v1

This looks good. The textContent Attribute is not documented in MDN xul-label page...

This patch also changes the Multiday-View boxes to wrap - was this intended?
On my lightning where I keep the appointments of all my family this would greatly reduce the readability.

I will continue with this but only for the agenda-view, as this is the scope of the bug.
Attachment #766923 - Flags: feedback?(Mozilla) → feedback+
(Assignee)

Updated

5 years ago
Attachment #766667 - Flags: review?(philipp)
(Assignee)

Updated

5 years ago
Keywords: uiwanted
textContent is the general DOM attribute for content of elements/nodes, probably thats why its not documented there. We should add a note though.

Anyway, this was hacked together, the side effects are not necessarily intended. If there is a way to make it wrap for multiday view I don't think it would be so bad though. The problem with multiday view though is that the box size are very delicate. The box must not change size because the text wraps.
Don't make me scrolling in the calendar views just because the title of an event is too long.

If reusing the existing code from calendar view is showing to be complicated, why not create simple new code that is targeted for the agenda list view and its requirements?
(Assignee)

Comment 9

5 years ago
Created attachment 767928 [details]
proposed look of today-pane agenda

I also don't want the multiday view get multiline events.
So I keep it to the Today-Pane.

This is how it looks so far.
It still needs some testing and we need to decide if we wrap the allday-events too.
(In reply to Stefan Sitter from comment #8)
> Don't make me scrolling in the calendar views just because the title of an
> event is too long.
Yes, this is a bug from the wip patch. Not intended.
(In reply to Markus Adrario [:Taraman] from comment #9)

> This is how it looks so far.
> It still needs some testing and we need to decide if we wrap the
> allday-events too.
lgtm. I would wrap allday events in the today pane. If you can make changes so it also works in the multiday view without making the scrollbar appear, then we might save the work of creating a separate binding with some duplicate code.
(Assignee)

Comment 12

5 years ago
Created attachment 769110 [details]
new look with allday-events wrapping

I managed to only get the allday-items wrap in today-pane.

This is what it will look.
Patch to follow shortly
Attachment #767928 - Attachment is obsolete: true
(Assignee)

Comment 13

5 years ago
Created attachment 769114 [details] [diff] [review]
Textwrap-Patch V1
Attachment #766667 - Attachment is obsolete: true
Attachment #766923 - Attachment is obsolete: true
Attachment #769114 - Flags: review?(philipp)
Comment on attachment 769114 [details] [diff] [review]
Textwrap-Patch V1

Review of attachment 769114 [details] [diff] [review]:
-----------------------------------------------------------------

Pretty cool, r=philipp
Attachment #769114 - Flags: review?(philipp) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
Created attachment 785836 [details] [diff] [review]
Textwrap Patch - v2

Here is the patch for checkin, which is the same as v1 but with correct patch header and commit message set.
Attachment #769114 - Attachment is obsolete: true
Attachment #785836 - Flags: review+
https://hg.mozilla.org/comm-central/rev/331134c6846e
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.8
Depends on: 909072

Updated

5 years ago
Depends on: 936192
You need to log in before you can comment on or make changes to this bug.