Add-ons search is returning nothing as selecting a certain firefox version doesn't include "Works with: Any Firefox" results

VERIFIED FIXED

Status

VERIFIED FIXED
6 years ago
3 years ago

People

(Reporter: samstep, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 650476 [details]
firefox_addon_search_not_working.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

1.Click on Firefox menu button, then click on Add-ons menu. 2 in the appeared search bar on the right, type any keyword to search Add-ons for (e.g. "bookmark"). Make sure that the search option is set on "Available Add-Ons" and not on "My Add-ons". Press enter. 


Actual results:

The progress bar appears and then comes back with "could not find any matching add-ons" error message. 


Expected results:

the list of add-ons matching the search criteria returned

Updated

6 years ago
Component: Untriaged → Search
Product: Firefox → addons.mozilla.org
Version: 14 Branch → unspecified

Comment 1

6 years ago
Changed headline to be more specific and confirmed known old bug. Probably a DUP of something else
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Add-ons search not working → Add-ons search is returning nothing as selecting a certain firefox version doesn't include "Works with: Any Firefox" results

Comment 2

6 years ago
Forgot to add: 'and "Works with All Systems"'

Comment 3

6 years ago
maybe Bug 767683 again.
Duplicate of this bug: 781539
https://addons.mozilla.org/en-US/firefox/search/?q=fire&appver=14.0.1&platform=windows

We moved to a new elasticsearch cluster in production. Thanks, Rob and Jason for investigating and fixing.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Verified FIXED; our amo.prod suite is now passing too.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.