Update mutt tests to work with latest processhandler changes in bug 776931

RESOLVED FIXED

Status

Testing Graveyard
Mozmill
RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: whimboo, Assigned: whimboo)

Tracking

({regression})

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
The above mentioned Mutt test is broken due to the changes of the process handler.

ERROR: test_relative_path (testprofilepath.TestProfilePath)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Volumes/data/code/mozmill/mutt/mutt/tests/python/testprofilepath.py", line 38, in test_relative_path
    code = process.waitForFinish(timeout=120)
  File "/Volumes/data/code/mozbase/mozprocess/mozprocess/processhandler.py", line 713, in waitForFinish
    return self.proc.wait()
AttributeError: 'ProcessHandler' object has no attribute 'proc'

Keep in mind that we need bug 781105 solved first before we can land this patch.
(Assignee)

Comment 1

6 years ago
Well, we should also fix the cli/options_tests_and_manifest.py test to not make use of subprocess directly but use ProcessHandler.
Summary: testprofilepath.py broken due to processhandler changes in bug 776931 → Update mutt tests to work with latest processhandler changes in bug 776931
(Assignee)

Comment 2

6 years ago
Created attachment 650494 [details]
Pointer to Github pull request: https://github.com/mozilla/mozmill/pull/85

Pointer to Github pull-request
(Assignee)

Updated

6 years ago
Attachment #650494 - Flags: review?(ahalberstadt)
(Assignee)

Comment 3

6 years ago
Before we can land this patch we have to include the version bump to mozrunner 5.9 in the pull request.
Whiteboard: [see comment 3 before landing]
Comment on attachment 650494 [details]
Pointer to Github pull request: https://github.com/mozilla/mozmill/pull/85

Looks good, thanks!
Attachment #650494 - Flags: review?(ahalberstadt) → review+
(Assignee)

Comment 5

6 years ago
Upgraded version dependencies. Now lets wait for Mozrunner 5.9.
Whiteboard: [see comment 3 before landing] → [needs mozrunner=5.9 before landing]
(Assignee)

Comment 6

6 years ago
https://github.com/mozilla/mozmill/commit/b4725db8678533f81363e81dcbb45a3770a0780d
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [needs mozrunner=5.9 before landing]
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.