pushlog not working on my user repo

RESOLVED DUPLICATE of bug 794143

Status

Developer Services
General
RESOLVED DUPLICATE of bug 794143
6 years ago
4 years ago

People

(Reporter: bhearsum, Assigned: fox2mike)

Tracking

Details

(Reporter)

Description

6 years ago
I don't really care about pushlog on my user repo, but I wanted to file this in case it's an issue that may become more widely spread.

I recloned my "tools" user repo yesterday (prior to reverting the mount options) and ever since then I've been getting the following message when pushing to it:
remote: error: changegroup.z_loghistory hook raised an exception: attempt to write a readonly database

I think bkero saw a permissions problem yesterday before getting bogged down with the slowness problems.

Comment 1

6 years ago
Hmm... I suspect Developer Services would be better equipped to handle this... moving!
Assignee: server-ops-webops → server-ops-devservices
Component: Server Operations: Web Operations → Server Operations: Developer Services
QA Contact: release → shyam

Comment 2

6 years ago
-rw-r--r--  1                   48 scm_level_1    0 Aug  8 10:07 pushlog2.db

Pushlog was owned by userid 48, and group perms only had read access.  I'm not sure why yet.

Comment 3

6 years ago
chmod g+w until I find out why
(Reporter)

Comment 4

6 years ago
I'm getting remote: error: changegroup.z_loghistory hook raised an exception: [Errno 1] Operation not permitted: '/repo/hg/mozilla/users/bhearsum_mozilla.com/tools/.hg/pushlog2.db'
 now
Chris is having a similar problem today:

[09:14:09] <catlee> [00:27:35] hey, just got this when trying to push to one of my user repos: remote: error: changegroup.z_loghistory hook raised an exception: attempt to write a readonly database
I've seen the same problem with new l10n repos as well..  Only thing that I know of that changed was the ordering of hooks.  However this would not affect perms on the new repo creation.

Catlee hit this problem again.
This is still busted on my user repo. Are you still debugging?
(Assignee)

Comment 8

6 years ago
Yeah, we're seeing this a little more widespread than we'd like and still no idea of what's actually causing this. 

It's probably easier to fix on the user repos, since we can just make you owners of the file and it shouldn't matter, but it's not a long term fix.

I'm digging around on this today.
See Also: → bug 790467, bug 791864
(Assignee)

Comment 9

6 years ago
(In reply to Corey Shields [:cshields] from comment #6)
> I've seen the same problem with new l10n repos as well..  Only thing that I
> know of that changed was the ordering of hooks.  However this would not
> affect perms on the new repo creation.

What ordering what changed?
I tried to reproduce using hg from macports, version 2.0.1 and 2.3, using fresh user clones of tools and buildbot repos (pushlog-test1, 2, and 3). No problems pushing commits up. 

bhearsum, catlee - are you push from a git or hg repo to hg.m.o ? Just a random idea.
(Reporter)

Comment 11

6 years ago
I'm pushing from hg. My usual workflow is:
* Delete user repo
* Reclone from eg. /build/buildbot-configs
* Clone new user repo
* Copy some changes in
* Commit & push

Comment 12

6 years ago
I've seen this on http://hg.mozilla.org/users/axel_mozilla.com/it/, too.
(Assignee)

Comment 13

6 years ago
I think we've finally cracked this one, working on a proper solution before we roll it out. Sorry for the forward dupe.
Assignee: server-ops-devservices → shyam
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 794143
Component: Server Operations: Developer Services → General
Product: mozilla.org → Developer Services
You need to log in before you can comment on or make changes to this bug.