Closed Bug 781525 Opened 10 years ago Closed 10 years ago

Build process is broken while processing /dom/interfaces/base/nsIDOMJSWindow.idl


(Thunderbird :: Build Config, defect)

Not set


(Not tracked)



(Reporter: fredbezies, Unassigned)


I was trying to build today a trunk version of thunderbird on archlinux (following archlinux specifics found here :, and build process is stopped with that log :

Traceback (most recent call last):
  File "/home/fred/logs/mail/src/mozilla/config/", line 56, in <module>
  File "/home/fred/logs/mail/src/mozilla/config/", line 48, in main
    execfile(script, frozenglobals)
  File "/home/fred/logs/mail/objdir-tb/mozilla/dist/sdk/bin/", line 483, in <module>
    idl = p.parse(open(file).read(), filename=file)
  File "/home/fred/logs/mail/objdir-tb/mozilla/dist/sdk/bin/", line 1575, in parse
    idl = self.parser.parse(lexer=self)
  File "/home/fred/logs/mail/objdir-tb/mozilla/dist/sdk/bin/ply/", line 265, in parse
    return self.parseopt_notrack(input,lexer,debug,tracking,tokenfunc)
  File "/home/fred/logs/mail/objdir-tb/mozilla/dist/sdk/bin/ply/", line 921, in parseopt_notrack
    lookahead = get_token()     # Get the next token
  File "/home/fred/logs/mail/objdir-tb/mozilla/dist/sdk/bin/", line 1564, in token
    t = self.lexer.token()
  File "/home/fred/logs/mail/objdir-tb/mozilla/dist/sdk/bin/ply/", line 384, in token
    newtok = self.lexerrorf(tok)
  File "/home/fred/logs/mail/objdir-tb/mozilla/dist/sdk/bin/", line 1174, in t_ANY_error
xpidl.IDLError: error: unrecognized input, /home/fred/logs/mail/src/mozilla/dom/interfaces/base/nsIDOMJSWindow.idl line 81:46
  readonly attribute nsIDOMWindow             _content;
make[4]: *** [_xpidlgen/nsIDOMJSWindow.h] Error 1
Side effect of bug 774032 ?
(In reply to Frederic Bezies from comment #1)
> Side effect of bug 774032 ?

Certainly not.

That being said, we have plenty of python in the code base, and most of it is not compatible with python3.
I was thinking of this bug because :

1) I was in holiday between between july 31 and august 8.
2) nsIDOMJSWindow.idl last update was related to this bug, at least in the calling it.

And what is strange is that firefox trunk code get build flawlessly.

So, any idea, please ?
What is the value of PYTHON in config/ when you build firefox? and what is its value when you build thunderbird?
For firefox :

PYTHON = /home/fred/logs/fox/objdir-fx/_virtualenv/bin/python

For thunderbird :

PYTHON		= /usr/bin/python2
what about mozilla/config/
what does each of these say with --version? (/home/fred/logs/fox/objdir-fx/_virtualenv/bin/python --version, etc.)
Took PYTHON value from both mozilla/config/ ; and about python versions.

Firefox :

[fred@fredo-arch objdir-fx]$ _virtualenv/bin/python --version
Python 2.7.3

Thunderbird :

/usr/bin/python2 --version
Python 2.7.3

If it helps, here is my thunderbird .mozconfig :

# See for build instructions.

export AUTOCONF=autoconf-2.13

ac_add_options --enable-application=mail
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../objdir-tb
mk_add_options MOZ_MAKE_FLAGS=-j4

# Options for ‘configure’ (same as command-line options).
ac_add_options --enable-optimize
ac_add_options --disable-debug
ac_add_options --disable-tests
ac_add_options --disable-crashreporter
ac_add_options --with-ccache
ac_add_options --disable-installer
ac_add_options --disable-warnings-as-errors
Then this has nothing to do with python3.

Now, re-reading the original error, it seems this is caused by bug 780146
I supposed python3 was guilty here,as it is a python3 error.

Thanks for the info !
Yes, but the XPIDL parser should handle this. In particular, the tree isn't burning. (At least not with this error.)
It turns out that I had old versions of all over the shop.

I tried removing $objdir/mozilla/sdk/bin/ and the build system just put it back.

I tried removing $objdir/mozilla/xpcom/idl-parser/cache/ too but to no avail.

Eventually I discovered $srcdir/mozilla/xpcom/idl-parser/ was an old version.

At last my build is progressing!
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 723861
You need to log in before you can comment on or make changes to this bug.