start_purchase: Datetime provided to 'created' field doesn't appear to be a valid datetime string: ''

RESOLVED WONTFIX

Status

Marketplace
Payments/Refunds
RESOLVED WONTFIX
6 years ago
4 years ago

People

(Reporter: kumar, Unassigned)

Tracking

x86
Mac OS X
Points:
---

Details

Solitude response: Datetime provided to 'created' field doesn't appear to be a valid datetime string: ''

Full exception: http://sentry.dmz.phx1.mozilla.com/marketplace-dev/group/1785/

SolitudeError: There was an error with that request.

Stacktrace (most recent call last):

  File "django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "amo/decorators.py", line 29, in wrapper
    return func(request, *args, **kw)

  File "addons/decorators.py", line 32, in wrapper
    return f(request, addon, *args, **kw)

  File "addons/decorators.py", line 58, in wrapper
    return f(request, addon, *args, **kw)

  File "addons/decorators.py", line 95, in wrapper
    return f(request, addon, *args, **kw)

  File "amo/decorators.py", line 156, in wrapper
    return f(*args, **kw)

  File "amo/decorators.py", line 148, in wrapper
    return f(*args, **kw)

  File "amo/decorators.py", line 50, in wrapper
    return f(request, *args, **kw)

  File "mkt/purchase/views.py", line 70, in purchase
    amount, currency, uuid_, contrib_for = start_purchase(request, addon)

  File "mkt/purchase/views.py", line 58, in start_purchase
    client.create_seller_for_pay(addon)

  File "lib/pay_server/__init__.py", line 97, in create_seller_for_pay
    obj = client.create_seller_paypal(addon)

  File "lib/pay_server/__init__.py", line 73, in create_seller_paypal
    res = self.get_seller(filters={'uuid': seller})

  File "lib/pay_server/base.py", line 147, in wrapped
    return self.call(url, method, data=data)

  File "lib/pay_server/base.py", line 125, in call
    code=code)
Assignee: nobody → xwraithanx
Target Milestone: --- → 2012-08-16
Whiteboard: [ye-olde-paypal]
Target Milestone: 2012-08-16 → ---
I'm not sure if this is still a bug or not
Whiteboard: [ye-olde-paypal]

Comment 2

6 years ago
Paypal issue. Ignore.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX

Comment 3

4 years ago
Just occurred on dev:

http://sentry.dmz.phx1.mozilla.com/marketplace-dev/marketplace-dev/group/21443/
Assignee: wraithan → amckay
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 4

4 years ago
Things got restarted and it magically went away. Couldn't reproduce locally. What the.
Assignee: amckay → nobody

Updated

4 years ago
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.