[WebAPI] WebTelephony: Keep an outgoing call on hold and emulator crashes

RESOLVED DUPLICATE of bug 790463

Status

()

RESOLVED DUPLICATE of bug 790463
7 years ago
6 years ago

People

(Reporter: rwood, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 650633 [details]
Log files

Using the B2G WebTelephony API.

If an outgoing call is kept on hold for any length of time (and not resumed immediately) the emulator crashes with the following assertion:

emulator64-arm: external/qemu/telephony/android_modem.c:2103: voice_call_event: Assertion `0 && "unreachable event call state"' failed.
./run-emulator.sh: line 40:  5831 Aborted

If the held call is resumed immediately instead of pausing for a couple of seconds, the call is reconnected fine (no assertion).  Only happens with outgoing calls - an incoming call can be kept held for the same duration and then resumes just fine.

To reproduce: Run the attached B2G Marionette WebTelephony test on the arm emulator (test_outgoing_hold_resume.js).  Expect pass, get failure with emulator assertion.

Running the test on arm emulator built Aug-9, Ubuntu 12.04 x64 VM.  See attached logcat/zip.
(Reporter)

Updated

7 years ago
OS: Windows 7 → Gonk
Hardware: x86_64 → All
(Reporter)

Comment 1

6 years ago
This is the same issue as 790463.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 790463
You need to log in before you can comment on or make changes to this bug.