Can't set onXxxx handlers in mozPeerConnection (on alder)

RESOLVED WORKSFORME

Status

()

Core
WebRTC
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: jesup, Assigned: anant)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [WebRTC], [blocking-webrtc-])

(Reporter)

Description

6 years ago
Setting an onXxxx attribute (such as onAddTrack) fails with NS_ERROR_XPC_CANT_MODIFY_PROP_ON_WN: Cannot modify properties of a WrappedNative

This appears to be caused by IPeerConnectionObserver's methods being instantiated by xpconnect and added to mozPeerConnection (it appears).
(Assignee)

Comment 1

6 years ago
When we are able to extend EventTarget in JS, we should be able to solve this.
Depends on: 731746

Updated

6 years ago
Whiteboard: [WebRTC], [blocking-webrtc+]
(Reporter)

Comment 2

6 years ago
marking non-blocking.  I believe we've worked around this, at most we have some leakage of unsettable properties into mozRTCPeerConnection - and I'm not sure it's still even visible to the outside world.
Whiteboard: [WebRTC], [blocking-webrtc+] → [WebRTC], [blocking-webrtc-]
(Reporter)

Comment 3

5 years ago
Fixed long ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.