int-to-pointer-cast build error in GCC 4.6 in nsDOMClassInfo.cpp

RESOLVED DUPLICATE of bug 781058

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 781058
5 years ago
5 years ago

People

(Reporter: bjacob, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 650710 [details] [diff] [review]
fix build of nsDOMClassInfo

Fallout from bug 743573.
Attachment #650710 - Flags: review?(mounir)
I swear I did fix this one!
Comment on attachment 650710 [details] [diff] [review]
fix build of nsDOMClassInfo

Review of attachment 650710 [details] [diff] [review]:
-----------------------------------------------------------------

r=me either way

::: dom/base/nsDOMClassInfo.cpp
@@ +9001,5 @@
>  static inline void *
>  FlagsToPrivate(PRUint32 flags)
>  {
>    JS_ASSERT((flags & (1 << 31)) == 0);
> +  return (void *)(uintptr_t)(flags << 1);

What about:
return reinterpret_cast<void*>(static_cast<uintptr_t>(flags << 1));
Attachment #650710 - Flags: review?(mounir) → review+
(Reporter)

Comment 3

5 years ago
Sure.
(Reporter)

Comment 4

5 years ago
Ms2ger fixed it yesterday.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 781058
You need to log in before you can comment on or make changes to this bug.