XMLHttpRequest.upload.onLoadend is treated as XMLHttpRequest.onLoadend

RESOLVED DUPLICATE of bug 637002

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 637002
5 years ago
5 years ago

People

(Reporter: mafooster, Unassigned)

Tracking

17 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8) AppleWebKit/536.25 (KHTML, like Gecko) Version/6.0 Safari/536.25

Steps to reproduce:

   XMLHttpRequest.upload.addEventListener("progress", uploadProgress, false);
   XMLHttpRequest.upload.addEventListener("loadend", showProcessing, false);

   XMLHttpRequest.addEventListener("load", uploadComplete, false);



Actual results:

the loadend state doesnt show unless an alert is put in as a break in the script.

the page shows the 'progress' state and then then 'load' state, despite the fact that there is a 5 second delay between the 'loadend' and 'load' when the backend script is taken into consideration.

Present in v14 and the nightly v17

ie: it calls the  xhr.upload.loadend as if it was xhr.loadend/xhr.load

This does not occur in chrome/opera/safari


Expected results:

The xhr.upload.loadend should display after the file has finnished uploading to the webserver until the reciving backend script has finnished loading. (Imagine a  "Please wait while processing" message for the end user)

This works as intended in chrome/opera/safari

see files.dotddq.com/uploader/index.php for demonstration
Component: Untriaged → DOM: Mozilla Extensions
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 637002
(Assignee)

Updated

5 years ago
Component: DOM: Mozilla Extensions → DOM
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.