Trying to stream audio through mozGetUserMedia, stopping, and try accessing it again - errors out with NO_DEVICES_FOUND on any subsequent access

RESOLVED DUPLICATE of bug 773646

Status

()

Core
WebRTC: Audio/Video
RESOLVED DUPLICATE of bug 773646
6 years ago
6 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Steps:

1. Hook up a USB headset to your system
2. Go to https://people.mozilla.com/~anarayanan/gum_test.html
3. Go to audio

Expected:

The audio stream should start playing back. Generating sound should cause you to hear that sound as well.

Actual:

NO_DEVICES_FOUND is thrown instead. I cannot get any audio playing back.
(Reporter)

Comment 1

6 years ago
Regression likely by bug 774357. Was working on 8/1/2012 Nightly build.
Keywords: regression
(Reporter)

Updated

6 years ago
Whiteboard: [getUserMedia], [blocking-gum+]
(Reporter)

Updated

6 years ago
Blocks: 774357
(Reporter)

Comment 2

6 years ago
Rewording title - so this appears to happen after you stop the audio on https://people.mozilla.com/~anarayanan/gum_test.html. After you select stop, any time you ever try to access audio again it will not work and instead throw NO_DEVICES_FOUND.
Summary: Trying to stream audio through mozGetUserMedia through a USB headset - errors out with NO_DEVICES_FOUND → Trying to stream audio through mozGetUserMedia on 2nd try - errors out with NO_DEVICES_FOUND
(Reporter)

Comment 3

6 years ago
Note - Even closing firefox, restarting and going to https://people.mozilla.com/~anarayanan/gum_test.html again on audio will still throw the NO_DEVICES_FOUND error.
(Reporter)

Updated

6 years ago
Summary: Trying to stream audio through mozGetUserMedia on 2nd try - errors out with NO_DEVICES_FOUND → Trying to stream audio through mozGetUserMedia, stopping, and try accessing it again - errors out with NO_DEVICES_FOUND on any subsequent access
(Reporter)

Comment 4

6 years ago
Note that a browser restart does not fix this problem, so this is different than bug 773646.
(Reporter)

Comment 5

6 years ago
And looks like I wasn't right. This isn't a new regression. My bad. It is a dup.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Keywords: regression
Resolution: --- → DUPLICATE
Whiteboard: [getUserMedia], [blocking-gum+]
Duplicate of bug: 773646
(Reporter)

Updated

6 years ago
No longer blocks: 774357
You need to log in before you can comment on or make changes to this bug.