after temporary network disconnect, failed page will not show again until after FF restart

RESOLVED INCOMPLETE

Status

()

Core
Networking
RESOLVED INCOMPLETE
5 years ago
5 years ago

People

(Reporter: Benno Schulenberg, Unassigned)

Tracking

14 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713225625

Steps to reproduce:

I tried to reach a website after the ethernet cable had accidently become disconnected.  And tried a second time.  Then I saw the disconnected cable, reconnected it, and tried again and again and again, to no avail.


Actual results:

The website would not show again, no matter how many times I tried.  Only after a restart of FF was the page shown again.

Example: type  gabel.de  into the address bar and hit Enter.  A green page is shown.  Then disconnect the network cable and hit F5 (Reload).  Server not found, of course.  Hit Reload again (important).  Then reconnect the cable, wait for the connection to establish, then hit Reload again -- nothing happens.  Hit it again -- the little wheel starts turning clockwise, but nothing happens.  Hit Reload for the fifth time -- the little wheel now turns counterclockwise, but nothing happens.  It keeps turning forever, it doesn't even time out.  (Now type  www  at the start of the address bar and hit Enter.  The page is shown again.  Now delete the www again and hit Enter -- again FF will never again connect.)


Expected results:

Obviously FF should not somehow "remember" its failure to connect, but should actually try and do it.

Updated

5 years ago
Duplicate of this bug: 781961
I cannot reproduce this with Firefox 14.0.1 on Ubuntu 12.04. Tried to follow your steps:

1. Open gabel.de in a new tab
2. Disconnect network
3. F5 to reload the tab
> Server not found
4. Reload the tab again
> Server not found
5. Reconnect network
6. Reload tab again
> Webpage loads

If this is reproducible for you please try the latest Nightly with a new profile to confirm and provide more details so we can try to reproduce this locally. Thank you.
Component: Untriaged → Networking
Product: Firefox → Core

Comment 3

5 years ago
Are you using a proxy, or VPN?

Comment 4

5 years ago
I don't. The connection is not the problem but I suspect of Tab Mix
Plus plugin. I will do some more tests in the next few hours with a
clean installation and profile and I will write to you asap.
Regards...
(Reporter)

Comment 5

5 years ago
With « http://gabel.de » I cannot reproduce this any more on
FF-16.0.2, but can with several other webpages, for example
with « http://translationproject.org/team/nl.html ».

Can anyone confirm?
(Reporter)

Comment 6

5 years ago
Hmm, it must be something in my profile.  When I start with a
clean profile (my current profile and profiles.ini moved out
of the way), things reload fine after a temporary disconnect.
It's probably due to an add-on in your profile or something bad in your cache. That's typically the cause of problems which go away in a new profile. 

If you can show this is related to a particular Firefox add-on then this should be reported to the add-on developer and is not a Firefox bug. If you can show this is related to a specific website then this might be a bug for Tech Evangelism. If you can show this is related to something going wrong in your cache then it might be worth pursuing further as a Firefox bug. 

Unfortunately, I don't see there is anything we can take action on in this bug. I'm going to resolve this bug INCOMPLETE since there's nothing concrete we can action in terms of this being a bug in Firefox. If you can provide any actionable evidence to the contrary, please feel free to reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.