Clicking "Restart to Update" should produce an immediate effect

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: bj, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Steps to reproduce:
- Wait until an updated version is available.
- Open Help/About Nightly.
- Click "Restart to Update".

Expected:
- The click should be acknowledged "immediately" (under 1/10 second).

Actual:
- It can take over a second before there is a visible change on the screen.

Today, and some previous days, I clicked a second time as I wasn't sure the click happened--even though I know it takes a while for that button to act.

Suggestion: Gray out the button and change the text to "Restart in progress" as soon as the click occurs, then perform the actions to restart the browser.

I have observed this delay on Ubuntu, Windows XP, and Windows 7. I have not tried to measure whether one OS is a worse offender than the others.
FWIW, I noticed this Behavior too across all supported Branches since Bug 307181 landed.
Component: General → Application Update
Product: Firefox → Toolkit

Comment 2

3 years ago
I can't detect any significant delay.
Do you still see this?
Severity: normal → minor
Flags: needinfo?(bj)
(Reporter)

Comment 3

3 years ago
There is now an immediate action (the main window goes away). The update window goes away after a second.

Thanks for cleaning up old tickets. This is an especially fortuitous time to ask about this ticket as I'm switching to a much faster new computer soon.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(bj)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.