Note: There are a few cases of duplicates in user autocompletion which are being worked on.

DESCRIPTION of ALARM component resets to "Mozilla Standardbeschreibung" in Lightning via CalDAV

RESOLVED FIXED in 1.9

Status

Calendar
Provider: CalDAV
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: david.binkovic, Assigned: Fallen)

Tracking

Lightning 1.6

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.60 Safari/537.1

Steps to reproduce:

Receive an appointment with e.g. the following ALARM component:

BEGIN:VALARM
TRIGGER;VALUE=DURATION:-PT15M
ACTION:DISPLAY
DESCRIPTION:My description
END:VALARM

Open the appointment details window, close the dialog again by clicking the "X" icon


Actual results:

- Confirmation window asking if changes should be saved
- ALARM gets changed to 


BEGIN:VALARM
TRIGGER;VALUE=DURATION:-PT15M
ACTION:DISPLAY
DESCRIPTION:Mozilla Standardbeschreibung
END:VALARM



Expected results:

- No confirmation window, since nothing was changed
- No change of the ALARM DESCRIPTION
(Reporter)

Comment 1

5 years ago
Note: It works (i.e. no confirmation popup, no changes made) when the appointment's ALARM already contains a description "Mozilla Standardbeschreibung" when initially being received by Lightning.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

5 years ago
Created attachment 652082 [details] [diff] [review]
Fix - v1
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #652082 - Flags: review?(matthew.mecca)
I've modified my 1.7b3 Lightning with these changes but at least after opening an appointment and closing it it still asks if I want to save my changes while I haven't done any.
But at least the event as sent back to the caldav server has the original description for the alarm AFAICS. Just the dialog still thinks something changed.
Status: ASSIGNED → NEW
(Assignee)

Comment 4

5 years ago
Yeah, there is another bug open on that. Some X-Prop is being set, related to notifications.
Status: NEW → ASSIGNED
Comment on attachment 652082 [details] [diff] [review]
Fix - v1

Looks good. r=mmecca
Attachment #652082 - Flags: review?(matthew.mecca) → review+
(Assignee)

Comment 6

5 years ago
Pushed to comm-central changeset c4c12e6a975a
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.9
You need to log in before you can comment on or make changes to this bug.