New 2.14a build bookmark-buggy

RESOLVED DUPLICATE of bug 777005

Status

SeaMonkey
Bookmarks & History
P1
major
RESOLVED DUPLICATE of bug 777005
5 years ago
5 years ago

People

(Reporter: Rocco Stilo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:16.0) Gecko/16.0 Firefox/16.0 SeaMonkey/2.13a2
Build ID: 20120806013003

Steps to reproduce:

Installed new 2.14a build online today. From bookmark menu, I don't see my bookmarks and folders, but only SeaMonkey default folders (Toolbar, Unsorted, etc.). To access my bookmarks, I must choose Manage Bookmarks... and click on them on the window.
(Reporter)

Updated

5 years ago
Severity: normal → major
Component: General → Bookmarks & History
Priority: -- → P1
Hardware: x86 → Other
Version: unspecified → Trunk

Comment 1

5 years ago
Confirmed.

Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/17.0 Firefox/17.0 SeaMonkey/2.14a1
Build identifier: 20120810003003

Perhaps this:

Error: TypeError: cannot use the given object as a weak map key
Source File: chrome://communicator/content/places/treeView.js
Line: 1194

1194:
      this._cellProperties.set(node, properties);
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

5 years ago
The other error I am seeing:
 
 
Error: NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: '[JavaScript Error: "cannot use the given object as a weak map key" {file: "chrome://communicator/content/places/browserPlacesViews.js" line: 72}]' when calling method: [nsINavHistoryResultObserver::result]
Source File: chrome://communicator/content/places/browserPlacesViews.js
Line: 49
 
 
49:
    result.addObserver(this, false);
OS: Mac OS X → All

Comment 3

5 years ago
The Weak Map errors are Bug 777005. Not sure if this is related.
(In reply to Philip Chee from comment #3)
> The Weak Map errors are Bug 777005. Not sure if this is related.

Bug 777005 was opened 2012-07-24 and its patches haven't landed yet. The bookmark menu behaved correctly until yesterday, or the day before at the earliest. I confirm that today I don't see any submenus of the Bookmark menu in:

Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/17.0 Firefox/17.0 SeaMonkey/2.14a1 ID:20120809115013 c-c:71eae60afbf6 m-c:ed5c848f50e0

which is an hourly about half a day older than what therube used in comment #1, and on a different platform. "Bookmarks Toolbar" and "Unsorted Bookmarks" both have "empty" submenus about 2x2 pixels in size, which is perhaps normal for the latter in my case, but not for the former. In addition I see nothing corresponding to the "Bookmarks Menu" folder which I have (and a big one) in the Bookmarks Manager.
Hardware: Other → All

Comment 5

5 years ago
Weak Map warnings are now fatal errors.

Sat Aug 11 2012 02:11:00
Error: TypeError: cannot use the given object as a weak map key
Source file: chrome://communicator/content/places/treeView.js
Line: 1194
 ----------
Sat Aug 11 2012 02:10:56
Error: cannot use the given object as a weak map key
Source file: chrome://communicator/content/places/controller.js
Line: 1312
 ----------
Sat Aug 11 2012 02:10:53
Error: NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: '[JavaScript Error: "cannot use the given object as a weak map key" {file: "chrome://communicator/content/places/browserPlacesViews.js" line: 72}]' when calling method: [nsINavHistoryResultObserver::result]
Source file: chrome://communicator/content/places/browserPlacesViews.js
Line: 49
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 777005
I suppose that there is no chance to rollback whatever it was that changed shortly before this hourly (comment #4) was built (long after bug 777005 was reported), and made those menus disappear? I was about to ask therube (or you Philip) to test the nightly for 2012-08-09, which was built only on Windows.

Comment 7

5 years ago
The change in mozilla-central was to change the weak map warnings to fatal errors. This means that the bookmark (and history) menus fail immediately instead of appearing to work but randomly encounter mysterious errors after a few while when garbage collection kicks in.
You need to log in before you can comment on or make changes to this bug.