Menu couldn't show sometimes while using fcitx

VERIFIED INVALID

Status

()

Core
Graphics
VERIFIED INVALID
6 years ago
6 years ago

People

(Reporter: Michael Lin, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20120810030512

Steps to reproduce:

I use firefox on ArchLinux x86-64. When i use want to input some Chinese characters, I need to use fcitx input method.   


Actual results:

After I input some Chinese characters with fcitx, all the menu(including right-button menu and address suggestions) couldn't show.


Expected results:

If i clicked on the menu button, the menu should pop up.
Does this still happen with a more recent Nightly? Can you please provide steps to reproduce including a URL we can use to test? Does this happen with en-US builds? Are you using a localized version of Firefox? Are you using a localized version of ArchLinux?
Component: Untriaged → General
(Reporter)

Comment 2

6 years ago
It still happens with the latest Nightly (in fact, all version later than 12.0).
Both en-US Nightly or zh-CN Beta has this bug. I am using a localized version of Archlinux.

You can try on WebQQ(web.qq.com, a Chinese IM web app) or Renren(www.renren.com, a Chinese SNS). The bug may happen after input some Chinese.
I also try the other input method(ibus), the bug happen too.
(In reply to Michael Lin from comment #2)
> It still happens with the latest Nightly (in fact, all version later than
> 12.0).

So this does not happen with Firefox 11? If so, can you please try to trace down a regression range? If it happens in 12 but not 11, the regression is likely in one of the Firefox 12.0a1 Nightly builds. You can use the mozregression[1] tool to make tracking down the range easier by giving it to dates. 

Firefox 12 was in Nightly from 2011-12-20 to 2012-01-31.
Keywords: regressionwindow-wanted
Version: 17 Branch → Trunk
(Reporter)

Comment 4

6 years ago
I found that this bug may has been fixed on 2012-08-21, the bug hasn't appeared over 12 hours.
I remembered that on Firefox 12 Nightly i found this bug. But at that time i don't know why it appears. These day i found that it may appear with fcitx.
(Reporter)

Comment 5

6 years ago
The bug appear on 2012-08-21, maybe it didn't be fixed.
I couldn't start Firefox 12 nightly(2011-12-20), it crashed.
(Reporter)

Comment 6

6 years ago
Today I run nightly in a terminal. It puts these words:

AUP timeline: Entered aup.init()                      	 (first event)
AUP timeline: * calling prefs.init()                  	 (0)
AUP timeline: * calling filterListener.init()         	 (1)
AUP timeline: * calling proxy.init()                  	 (0)
AUP timeline: * calling filterStorage.init()          	 (0)
AUP timeline: * Entered filterStorage.loadFromDisk()  	 (0)
AUP timeline: * * done locating patterns.ini file     	 (1)
AUP timeline: * * done parsing file                   	 (84)
AUP timeline: * * load complete, calling observers    	 (0)
AUP timeline: * filterStorage.loadFromDisk() done     	 (36)
AUP timeline: * calling policy.init()                 	 (0)
AUP timeline: * calling synchronizer.init()           	 (1)
AUP timeline: aup.init() done                         	 (0)
Failed to open VDPAU backend libvdpau_nvidia.so: 无法打开共享对象文件: 没有那个文件或目录
NOTE: child process received `Goodbye', closing down
Failed to open VDPAU backend libvdpau_nvidia.so: 无法打开共享对象文件: 没有那个文件或目录
Failed to open VDPAU backend libvdpau_nvidia.so: 无法打开共享对象文件: 没有那个文件或目录
Failed to open VDPAU backend libvdpau_nvidia.so: 无法打开共享对象文件: 没有那个文件或目录
Failed to open VDPAU backend libvdpau_nvidia.so: 无法打开共享对象文件: 没有那个文件或目录
Failed to open VDPAU backend libvdpau_nvidia.so: 无法打开共享对象文件: 没有那个文件或目录
Failed to open VDPAU backend libvdpau_nvidia.so: 无法打开共享对象文件: 没有那个文件或目录

(firefox:27080): Gdk-WARNING **: Native Windows wider or taller than 65535 pixels are not supported
Failed to open VDPAU backend libvdpau_nvidia.so: 无法打开共享对象文件: 没有那个文件或目录
Failed to open VDPAU backend libvdpau_nvidia.so: 无法打开共享对象文件: 没有那个文件或目录
*** At this time, I clicked on the menu and found the bug. ***
Could be graphics related, I don't know? Moving this to Core::Graphics to get a developer's opinion.
Component: General → Graphics
Product: Firefox → Core
Michael, can you please provide a copy of the Graphics section of your about:support page?
(Reporter)

Comment 9

6 years ago
Graphics
Adapter Description      X.Org -- Gallium 0.4 on AMD CAICOS
Vendor ID                X.Org
Device ID                Gallium 0.4 on AMD CAICOSDriver Version2.1 Mesa 8.0.4
WebGL Renderer           X.Org -- Gallium 0.4 on AMD CAICOS -- 2.1 Mesa 8.0.4
GPU Accelerated Windows  0
AzureCanvasBackend           none
AzureFallbackCanvasBackend   none
AzureContentBackend          none
I'm confused -- your about:support page shows you are using an AMD graphics driver yet comment 6 shows NVidia libraries being loaded. Does your system have both (ie. an integrated AMD card and discrete NVidia card, or vice versa)?
(Reporter)

Comment 11

6 years ago
No, I only installed AMD graphics driver. I don't know why firefox want to load NVidia libraries.
The VDPAU thing looks like a red herring.
(Reporter)

Comment 13

6 years ago
Today a member from LUG answered me about this problem. There are something wrong with my input method config, but not the bug of Firefox. The bug disappeared while i use the right config.
I don't know why the bug happens with Firefox...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
Thanks for following up, Michael.
Status: RESOLVED → VERIFIED
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.