Last Comment Bug 781975 - Missing right click menu's on Firefox Bookmarks Toolbar items in OSX
: Missing right click menu's on Firefox Bookmarks Toolbar items in OSX
Status: RESOLVED INVALID
:
Product: Firefox
Classification: Client Software
Component: Toolbars and Customization (show other bugs)
: 14 Branch
: x86 Mac OS X
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-10 16:16 PDT by Plasma
Modified: 2012-10-09 04:01 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Plasma 2012-08-10 16:16:07 PDT
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

Using Firefox in Mac OS X 10.7 Right Click on an item on the Bookmark toolbar that is either in a folder on the toolbar or in the extended section under the ">>" button on the right hand side, you get no context menu displayed. 


Actual results:

Nothing happened, there was no menu shown. This makes renaming and editing bookmarks in folders or on the ">>" drop down from the right side of the toolbar impossible


Expected results:

Doing this with Firefox on Windows work fine, and on items that are visible on the toolbar on OSX reveals a context menu with Open, Cut, Copy, Paste, Properties etc. But it doesn't work on  not in toolbar folders or on items in the >> drop down list on OSX.
Comment 1 [:Aleksej] 2012-08-18 01:59:43 PDT
WFM on Debian GNU/Linux wheezy/sid x86_64 with Fx 15.0b4.
Comment 2 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-08-21 09:56:31 PDT
Please confirm that this happens on the latest Firefox Nightly in Safe Mode. You can get a nightly from nightly.mozilla.org. Safe Mode documentation can be found here:
http://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
Comment 3 Plasma 2012-09-07 03:53:53 PDT
Hi, Apologies for the delay I've been out of the country.

I have just tried with the nightly build "firefox-18.0a1.en-US.mac.dmg" in safe mode and I can confirm the issue is still present.
Comment 4 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-09-11 12:31:53 PDT
I can reproduce this in the latest Nightly, but I can also reproduce this back to Firefox 4. I can't see that this ever worked on Mac, which leads me to believe this is as designed behaviour. FWIW, this behaves exactly the same as Safari on Mac OSX.

I'm inclined to resolve this INVALID but please feel free to reopen this if evidence can be provided that this is a bug.
Comment 5 Ruben 2012-10-09 04:01:48 PDT
please reopen this as a feature request then

Note You need to log in before you can comment on or make changes to this bug.