Playing music using Audio in BananaBread regressed and is now glitchey

RESOLVED WORKSFORME

Status

()

Core
Audio/Video
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: azakai, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
STR:

1. Load http://www.syntensity.com/static/night13/low.html
2. Wait as it downloads and starts up. It will play background music - ignore that! Keep waiting until it says Press "fullscreen" to start the game" (and CPU goes to 0% - it finished starting up). Do not press fullscreen!
3. Listen to the new (more exciting) background music.

In Nightly, playback is glitchey - every second or so there is an interruption of static, making the music unpleasant to hear. I have disabled music in BananaBread because of this.

This is a recent regression, since it works OK on Aurora (and Beta).

Tested on Ubuntu.

Audio is played using an HTML Audio element (not the Audio Data API or anything else).
(Reporter)

Updated

6 years ago
Blocks: 710398
Keywords: regressionwindow-wanted
I can't reproduce this locally with the 2012-08-12 nightly build on Fedora 17 x86_64.  Can you reproduce this consistently?  Which build are you testing against?  Which Linux distribution are you running, and on what hardware?
(Reporter)

Comment 2

6 years ago
Hmm, I can't reproduce this anymore. The only change in my system is that I rebooted since I last tried (I could reproduce it very consistently before). So might have been an Ubuntu issue (10.10 32-bit), closing this.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Thanks.  That could be a variant of bug 761274, although we've had a workaround in the nightlies for a couple of weeks.
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.