update-named script too noisy

RESOLVED INVALID

Status

mozilla.org Graveyard
Server Operations
RESOLVED INVALID
5 years ago
3 years ago

People

(Reporter: ericz, Assigned: ericz)

Tracking

Details

(Assignee)

Description

5 years ago
I regularly get emails like the one below, mostly in the middle of the night when I'm on call.  These come frequently and prevent sleeping.  I've sometimes removed the lock file and things have improved...I feel we should be able to automatically script this so it fixes itself.  Or at least educate the SREs on what needs to be done.

------

Failed to acquire lockfile: /tmp/update-named.lock
Held by 28377

Likely an instance of /root/bin/update-named.sh is already running.  If this error continues there may be a stale lock file.
(Assignee)

Comment 1

5 years ago
Since this always fixes itself and is caused by svn timeouts, going to see if I can make it less noisy while still knowing if it breaks and doesn't fix itself.
Assignee: limed → eziegenhorn
Status: NEW → ASSIGNED
(Assignee)

Comment 2

5 years ago
digi is replacing the update-named.sh script as per bug 784656 so this is obsolete now.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.