url bar autocomplete does not choose correctly

RESOLVED DUPLICATE of bug 720266

Status

()

RESOLVED DUPLICATE of bug 720266
6 years ago
5 years ago

People

(Reporter: illumilore, Unassigned)

Tracking

14 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713224749

Steps to reproduce:

when typing in a url in the location bar, the drop down menu shows the websites that you most visit, but the autocomplete in the url bar chooses whatever is the shortest instead of most visited


Actual results:

na


Expected results:

na

Comment 1

6 years ago
It's the normal behavior see https://support.mozilla.org/en-US/kb/search-your-bookmarks-history-and-tabs-awesome-bar#w_url-autocomplete
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

6 years ago
"It's the normal behavior"

The autocompletion is not what this bug was for, it was for it choosing the wrong website.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

6 years ago
Can you post some clear steps regarding this? It's working fine for me.

Updated

6 years ago
Component: Untriaged → Autocomplete
Product: Firefox → Toolkit
(Reporter)

Comment 4

6 years ago
Start typing in the url bar, then take note of the url that autocompletes. This happens on both machines that I tested with firefox 14.0.1

Comment 5

6 years ago
This description is not enough, or it is already filed and maybe fixed.

These bugs may fit your description: bug 720081, bug 769994.
Component: Autocomplete → Location Bar
Product: Toolkit → Firefox
no info to debug anything, I couldn't understand the bug report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 7

6 years ago
What part of it did you not understand?
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
there are no steps to reproduce or examples, I can't figure what comment 0 is trying to show.
(Reporter)

Comment 9

6 years ago
example: Start typing in url to location bar. The awesome bar drop down menu that comes up has the most visited site as the first option. As the user types in a url, the autocomplete url functionality of firefox however does not have the most visited site as the completion option. It seems to just choose randomly as far as I can tell.
do you mean the inline completion done in the textfield? That is not related to the dropdown menu. It's not random too, it's just the best match among hosts you visited.

Comment 11

6 years ago
If comment #10, it’s duplicate of bug 720266.

Comment 12

5 years ago
(In reply to Marco Bonardo [:mak] from comment #10)
> do you mean the inline completion done in the textfield? That is not related
> to the dropdown menu. It's not random too, it's just the best match among
> hosts you visited.

A reply would be polite and helpful
Flags: needinfo?(illumilore)
Whiteboard: [closeme 2013-09-10]
(Reporter)

Comment 13

5 years ago
yes. what do you mean by best match?
Flags: needinfo?(illumilore)

Comment 14

5 years ago
This bug is a duplicate of bug 720266, but ill wants to know how inline autocomplete chooses the domain.
Whiteboard: [closeme 2013-09-10]

Comment 15

5 years ago
(In reply to Aleksej [:Aleksej] from comment #14)
> This bug is a duplicate of bug 720266, but ill wants to know how inline
> autocomplete chooses the domain.

then let's do the dup to close the bug. and get an explanation for ill later, or offline in a discussion group
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 720266
You need to log in before you can comment on or make changes to this bug.