Last Comment Bug 782155 - Set MACOSX_DEPLOYMENT_TARGET to 10.6 for all architectures
: Set MACOSX_DEPLOYMENT_TARGET to 10.6 for all architectures
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86 Mac OS X
: -- trivial (vote)
: mozilla17
Assigned To: Nomis101
:
: Gregory Szorc [:gps]
Mentors:
: 782156 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-12 14:56 PDT by Nomis101
Modified: 2012-08-15 09:49 PDT (History)
3 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (2.07 KB, patch)
2012-08-12 14:56 PDT, Nomis101
ted: review+
Details | Diff | Splinter Review
Patch v2 (3.62 KB, patch)
2012-08-13 12:14 PDT, Nomis101
ted: review+
Details | Diff | Splinter Review

Description Nomis101 2012-08-12 14:56:04 PDT
Created attachment 651228 [details] [diff] [review]
Patch

Now that we have removed 10.5 support on trunk, we can set MACOSX_DEPLOYMENT_TARGET to 10.6 for all architectures. This patch also cleans up unsupported powerpc-apple-darwin.
Comment 1 Ed Morley [:emorley] 2012-08-13 01:29:54 PDT
Isn't the case statement redundant now? :-)
Also presume js/src/configure.in will need changing too.
Comment 2 Nomis101 2012-08-13 02:45:04 PDT
(In reply to Ed Morley [:edmorley] from comment #1)
> Also presume js/src/configure.in will need changing too.
The JS part is Bug 782156.
Comment 3 Ed Morley [:emorley] 2012-08-13 04:46:11 PDT
Oh ok - not sure why a separate bug? 
Just didn't know about the JS part since it wasn't mentioned in comment 0 or filed in a build config component (I don't watch the JS component) :-)
Comment 4 Ted Mielczarek [:ted.mielczarek] 2012-08-13 11:07:30 PDT
Comment on attachment 651228 [details] [diff] [review]
Patch

Review of attachment 651228 [details] [diff] [review]:
-----------------------------------------------------------------

::: configure.in
@@ +909,3 @@
>              ;;
>            x86_64)
>              export MACOSX_DEPLOYMENT_TARGET=10.6

You can just get rid of the case statement entirely here, and always set it to 10.6.
Comment 5 Nomis101 2012-08-13 12:14:48 PDT
Created attachment 651500 [details] [diff] [review]
Patch v2

You mean like this?
Comment 6 Nomis101 2012-08-13 12:17:33 PDT
*** Bug 782156 has been marked as a duplicate of this bug. ***
Comment 7 Ted Mielczarek [:ted.mielczarek] 2012-08-14 05:30:46 PDT
Comment on attachment 651500 [details] [diff] [review]
Patch v2

Review of attachment 651500 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, thanks!
Comment 8 Ryan VanderMeulen [:RyanVM] 2012-08-14 17:54:35 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/16127a6e0bf3
Comment 9 Ed Morley [:emorley] 2012-08-15 09:49:02 PDT
https://hg.mozilla.org/mozilla-central/rev/16127a6e0bf3

Note You need to log in before you can comment on or make changes to this bug.