The default bug view has changed. See this FAQ.

[PP]support the locale in menus on Linux

VERIFIED FIXED in M7

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED FIXED
18 years ago
12 years ago

People

(Reporter: Erik van der Poel, Assigned: Erik van der Poel)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Checked in a fix)

(Assignee)

Description

18 years ago
As a first step towards fully multilingual menus on Linux, we need to support
the current locale by converting Unicode to the locale encoding before passing
the strings to the menu items.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M7
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 1

18 years ago
I checked in a fix. To test this, you will need to set the locale on your Unix
box before invoking apprunner. For example:

  setenv LANG ja_JP.ujis

On RedHat 5.2, you also need the following RPMs installed:

  skewer:/builds/erik/libwcsmbs-0.0.4-SNAP.i386.rpm
  skewer:/builds/erik/wcsmbs-locale-ja-0.4.6-SNAP.i386.rpm

To use these, you also need to set the following:

  setenv LD_PRELOAD /lib/libwcsmbs.so

Sorry, but that's the current state of affairs on RedHat 5.2, our reference
platform.

Updated

18 years ago
QA Contact: phillip → amasri

Comment 2

18 years ago
Changed QA contact to amasri@netscape.com.

Updated

18 years ago
Summary: support the locale in menus on Linux → [PP]support the locale in menus on Linux

Updated

18 years ago
Status: RESOLVED → REOPENED
QA Contact: amasri → chjung

Comment 3

18 years ago
Change QA contact to myself.
This bug fix works fine for normal menu labels.
But the other menu labels which have sub-menus,
still display dot characters "." instead of Japanese characters.
I verified it on M7-06-15-08.
Therefore, I'll reopen this bug for remain issue.
(Assignee)

Updated

18 years ago
Resolution: FIXED → ---
(Assignee)

Updated

18 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
Whiteboard: Checked in a fix
(Assignee)

Comment 4

18 years ago
*** Bug 6542 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 5

18 years ago
I verified the bug fix with M7-06-16-99-08
It worked fine.
Great job, Erik.

Comment 6

18 years ago
Moving all Widget Set bugs, past and present, to new HTML Form Controls
component per request from karnaze.  Widget Set component will be retired
shortly.
You need to log in before you can comment on or make changes to this bug.