If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Browser hangs (in gdk_event_free?) when clicking tabs

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
17 years ago
13 years ago

People

(Reporter: motrei, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.17-21mdk i686; en-US; rv:0.8.1+)
Gecko/20010426
BuildID:    2001043009

Go to http://www.pcworld.com . It opens on the tab named home. Click on any
other tab: no problem, the page displays. Now click back on the
tab named hom
e (which was where you came from). The browser locks up. 
This behaviour may be related to something specific on the home tab,
because clicking between other tabs seems to work.

I am running Mandrake Linux 7.2 with XFree86 4.0.1, glibc 2.1.3-16mdk,
gtk+-devel 1.2.8-6mdk . I also saw this behaviour on Mandrake 8.0
with glibc 2.2.2 (I dont have the gtk+ info).

I used gdb to attach to the relevant mozilla-bin thread (the other threads were
suspended. Here's the stack trace I got:

(gdb) where
#0  0x40873311 in _nss_nis_initgroups ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libpref.so
#1  0x400c9c81 in nsQueryInterface::operator() ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/libxpcom.so
#2  0x400c9d58 in nsCOMPtr_base::assign_from_helper ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/libxpcom.so
#3  0x40870348 in _nss_nis_initgroups ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libpref.so
#4  0x40f74aa5 in NSGetModule ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libcaps.so
#5  0x40f70361 in NSGetModule ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libcaps.so
#6  0x40f702af in NSGetModule ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libcaps.so
#7  0x4047d492 in NS_NewScriptHTMLButtonElement ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/libjsdom.so
#8  0x4014674f in js_GetProperty ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/libmozjs.so
#9  0x4013b541 in js_Interpret ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/libmozjs.so
#10 0x40135086 in js_Invoke ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/libmozjs.so
#11 0x4013bf65 in js_Interpret ()
---Type <return> to continue, or q <return> to quit---
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/libmozjs.so
#12 0x40135086 in js_Invoke ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/libmozjs.so
#13 0x4013527a in js_InternalInvoke ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/libmozjs.so
#14 0x40119225 in JS_CallFunctionValue ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/libmozjs.so
#15 0x404330b9 in nsJSContext::CallEventHandler ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/libjsdom.so
#16 0x4046edcc in nsJSEventListener::HandleEvent ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/libjsdom.so
#17 0x40bf912e in NSGetModule ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgkcontent.so
#18 0x40bf986f in NSGetModule ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgkcontent.so
#19 0x40d7921f in NSGetModule ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgkcontent.so
#20 0x40c0c7e7 in NSGetModule ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgkcontent.so
---Type <return> to continue, or q <return> to quit---
#21 0x40c16313 in NSGetModule ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgkcontent.so
#22 0x40d79396 in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgkcontent.so
#23 0x40c37106 in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgkcontent.so
#24 0x4100a371 in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgklayout.so
#25 0x4100a25d in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgklayout.so
#26 0x40c013e3 in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgkcontent.so
#27 0x40bffb31 in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgkcontent.so
#28 0x4100a450 in NSGetModule ()
from
/ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgklayout---Type
<return> to continue, or q <return> to quit---
.so
#29 0x4100a1ce in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgklayout.so
#30 0x411422eb in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgkview.so
#31 0x4114228f in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgkview.so
#32 0x4114228f in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgkview.so
#33 0x4114c6d3 in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgkview.so
#34 0x41141bf6 in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgkview.so
#35 0x4053f19e in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libwidget_gtk.so
#36 0x4053f0b0 in NSGetModule ()
---Type <return> to continue, or q <return> to quit---
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libwidget_gtk.so
#37 0x4053f233 in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libwidget_gtk.so
#38 0x4053fffa in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libwidget_gtk.so
#39 0x405441c1 in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libwidget_gtk.so
#40 0x4053994a in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libwidget_gtk.so
#41 0x40539625 in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libwidget_gtk.so
#42 0x406d0d00 in gdk_event_free () from /usr/lib/libgdk-1.2.so.0

The stack traces of 2 of the other threads showed they were blocked in poll().
The stack trace of the remaining thread showed it was blocked in sigsuspend as
displayed below:


#0  0x401fe17e in sigsuspend () from /lib/libc.so.6
#1  0x401d01a0 in pthread_setconcurrency () from /lib/libpthread.so.0
#2  0x401ccb20 in pthread_cond_wait () from /lib/libpthread.so.0
#3  0x401ab4a8 in PR_WaitCondVar ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/libnspr4.so
#4  0x401ab7da in PR_Wait ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/libnspr4.so
#5  0x409727dd in NSGetModule ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libnecko.so
#6  0x40972c64 in NSGetModule ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libnecko.so
#7  0x400c32fe in nsThread::Main ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/libxpcom.so
#8  0x401afbed in PR_Select ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/libnspr4.so
#9  0x401cde52 in pthread_detach () from /lib/libpthread.so.0


Reproducible: Always
Steps to Reproduce:
1.Go to http://www.pcworld.com
2.Click on one of the other tabs (I chose the reviews tab)
3.Now click on the "home" tab. The browser locks up

Actual Results:  
The browser locks up. I have to kill it from the command line.

Expected Results:  
It should have displayed the tab.

(gdb) where
#0  0x40873311 in _nss_nis_initgroups ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libpref.so
#1  0x400c9c81 in nsQueryInterface::operator() ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/libxpcom.so
#2  0x400c9d58 in nsCOMPtr_base::assign_from_helper ()
   f---Type <return> to continue, or q <return> to quit---

rom /ajay_local/mozilla/night30apr2001/mozilla-gcc295/libxpcom.so
#3  0x40870348 in _nss_nis_initgroups ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libpref.so
#4  0x40f74aa5 in NSGetModule ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libcaps.so
#5  0x40f70361 in NSGetModule ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libcaps.so
#6  0x40f702af in NSGetModule ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libcaps.so
#7  0x4047d492 in NS_NewScriptHTMLButtonElement ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/libjsdom.so
#8  0x4014674f in js_GetProperty ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/libmozjs.so
#9  0x4013b541 in js_Interpret ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/libmozjs.so
#10 0x40135086 in js_Invoke ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/libmozjs.so
#11 0x4013bf65 in js_Interpret ()
---Type <return> to continue, or q <return> to quit---
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/libmozjs.so
#12 0x40135086 in js_Invoke ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/libmozjs.so
#13 0x4013527a in js_InternalInvoke ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/libmozjs.so
#14 0x40119225 in JS_CallFunctionValue ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/libmozjs.so
#15 0x404330b9 in nsJSContext::CallEventHandler ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/libjsdom.so
#16 0x4046edcc in nsJSEventListener::HandleEvent ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/libjsdom.so
#17 0x40bf912e in NSGetModule ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgkcontent.so
#18 0x40bf986f in NSGetModule ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgkcontent.so
#19 0x40d7921f in NSGetModule ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgkcontent.so
#20 0x40c0c7e7 in NSGetModule ()
   from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgkcontent.so

#21 0x40c16313 in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgkcontent.so
#22 0x40d79396 in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgkcontent.so
#23 0x40c37106 in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgkcontent.so
#24 0x4100a371 in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgklayout.so
#25 0x4100a25d in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgklayout.so
#26 0x40c013e3 in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgkcontent.so
#27 0x40bffb31 in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgkcontent.so
#28 0x4100a450 in NSGetModule ()
from
/ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgklayout---Type
<return> to continue, or q <return> to quit---
.so
#29 0x4100a1ce in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgklayout.so
#30 0x411422eb in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgkview.so
#31 0x4114228f in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgkview.so
#32 0x4114228f in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgkview.so
#33 0x4114c6d3 in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgkview.so
#34 0x41141bf6 in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libgkview.so
#35 0x4053f19e in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libwidget_gtk.so
#36 0x4053f0b0 in NSGetModule ()
---Type <return> to continue, or q <return> to quit---
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libwidget_gtk.so
#37 0x4053f233 in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libwidget_gtk.so
#38 0x4053fffa in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libwidget_gtk.so
#39 0x405441c1 in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libwidget_gtk.so
#40 0x4053994a in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libwidget_gtk.so
#41 0x40539625 in NSGetModule ()
from /ajay_local/mozilla/night30apr2001/mozilla-gcc295/components/libwidget_gtk.so
#42 0x406d0d00 in gdk_event_free () from /usr/lib/libgdk-1.2.so.0
(Reporter)

Comment 1

17 years ago
Note: when it hangs, it seems to be taking > 90% CPU (on a 700Mhz Athlon).

I notice that this bug has not even been confirmed since it was entered. If
PC World magazine decides to review either mozilla or some netscape release
based on it, the first page they are likely to try would be their own. It
would be embarassing if the browser locked up when PCWorld tried to access
its own page (assuming the Windows version shows this bug, which may or may
not be the case).

Comment 2

17 years ago
Mozilla/5.0 (X11; U; Linux 2.4.2 i586; en-US; rv:0.9+) Gecko/20010508
Works for me - I can click on any tab, then click on the Home tab again with no
problem.
(Assignee)

Comment 3

17 years ago
worksforme with 050904 mozilla win32 build on win2K
(Reporter)

Comment 4

17 years ago
I rebuilt mozilla last night and tried it again: ITS FIXED!! Please close this
bug. 
(Assignee)

Comment 5

17 years ago
worksforme per reporter's comments.  Thanks for the folowup.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.