Duplication of messages after transfer by filter

RESOLVED WORKSFORME

Status

Thunderbird
Folder and Message Lists
RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: Mitra Ardron, Unassigned)

Tracking

16 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2014-11-01])

(Reporter)

Description

6 years ago
I'm seeing a lot of messages showing up duplicated, the symptom is going to a folder and finding two messages with the same subject line, and time. At first I thought I was on people's mailing lists twice, but I've ruled that out now. 

It could be correlated with having the message open in the reader at the time the Filter processes it (Filters run really slow and I've got a lot of them).

I've checked on the IMAP server and the messages are duplicated there as well, i.e. the folder index correctly reflects what the IMAP server thinks.

Comment 1

5 years ago
DOes it reproduce with beta version?
Flags: needinfo?(mitra_lists)
Whiteboard: [closeme 2013-06-25]
(Reporter)

Comment 2

5 years ago
I'm on 23.0a2 (2013-06-01) 

I haven't seen it related to filters, but I still see duplicates when I detach or delete an attachment, often a second copy of the message is created - one with, and one without, the attachments.   That might be a different instance of the same bug, or a completely different one.
Flags: needinfo?(mitra_lists)
(In reply to Mitra Ardron from comment #0)
> I've checked on the IMAP server and the messages are duplicated there as well, (snip)

Do you access same IMAP account from multiple IMAP clients? If so, and if multiple clients execute filter at same time, it's pretty normal phenomenon.

If IMAP Mbox accesse is from only one IMAP client==Tb any time, is server connection stable?
Because filter move consists of multiple steps, if connection loss occurs between sending of "uid xx copy TargetFolder" and next step of "uid xxx store +Flag \Deleted", phenomenon is pretty normal too, because "not-ended-yet filter move" is executed next time.

(In reply to Mitra Ardron from comment #2)
> I still see duplicates when I detach or delete an attachment,
> often a second copy of the message is created - one with, and one without, the attachments.

"Detach or delete" in IMAP consists of;
  (1) append(upload) of Detached or Deleted version of mail,
  (2) "uid xxx store +Flags \Deleted" to original mail.
Because number of relevant mails is only two, IMAP log size is not so huge. Get IMAP log and check IMAP level frow by Text Editor, and open separate bug if evidence of "Tb's bug" is seen in log, because it may be different from problem of comment #0 by message filter. Keep "one problem per a bug", please.
(Reporter)

Comment 4

5 years ago
I do use it from different clients, but none of the others are running filters.

It could be your 2nd problem, as I'm often on poor connections.

Updated

5 years ago
Whiteboard: [closeme 2013-06-25]

Comment 5

4 years ago
Mitra can you still reproduce?  

If no, please close bug.
If yes, please attach imap:5 protocol log, ref https://wiki.mozilla.org/MailNews:Logging
Flags: needinfo?(mitra_lists)
Whiteboard: [closeme 2014-11-01]
(Reporter)

Comment 6

4 years ago
I haven't seen this for while, but I no longer use filters as much to move messages around. 

I do see duplicate messages caused for other reasons - such as when I detach attachments, often the message appears with both a detached and non-detached version, I'm not sure if I posted that as a bug as well.
Flags: needinfo?(mitra_lists)

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.