Authentication problem is preventing submission

RESOLVED FIXED

Status

mozillaignite
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Will Barkis, Assigned: cturra)

Tracking

Details

(URL)

(Reporter)

Description

5 years ago
Hi,

We are 9 days from the end of an idea challenge in which people are submitting ideas for apps and now there seems to be a problem with submission to the challenge.

After receiving a couple of emails from people having trouble, I did some exploring.  

Basically, I'm having trouble submitting a new idea to the competition from a different account than will@mozillafoundation.org.  I tried doing it in a new browser with a new email address (eg barkisdev@gmail.com).  Mozilla Persona seems to sign me in but then just takes me back to the main https://www.mozillaignite.org page.  When I try to "Get Started" or "Create Submission" (from ../ideas/list/) it asks me to login/register and then it bounces me back to the homepage again.

So it's circular.

And FWIW, we were using Disqus for our authentication before and I'm not sure if we have switched now to Mozilla Person or if this is just an added layer.

Thanks, this is pretty urgent because people need to be able to submit to the challenge!

Will
Assignee: server-ops-webops → mburns
(In reply to Will Barkis from comment #0)
> Hi,
> 
> We are 9 days from the end of an idea challenge in which people are
> submitting ideas for apps and now there seems to be a problem with
> submission to the challenge.
> 
> After receiving a couple of emails from people having trouble, I did some
> exploring.  
> 
> Basically, I'm having trouble submitting a new idea to the competition from
> a different account than will@mozillafoundation.org.  I tried doing it in a
> new browser with a new email address (eg barkisdev@gmail.com).  Mozilla
> Persona seems to sign me in but then just takes me back to the main
> https://www.mozillaignite.org page.  When I try to "Get Started" or "Create
> Submission" (from ../ideas/list/) it asks me to login/register and then it
> bounces me back to the homepage again.
> 
> So it's circular.
> 
> And FWIW, we were using Disqus for our authentication before and I'm not
> sure if we have switched now to Mozilla Person or if this is just an added
> layer.
> 
> Thanks, this is pretty urgent because people need to be able to submit to
> the challenge!
> 
> Will

Will,

This sounds like an application level issue, as I was able to create https://mozillaignite.org/ideas/184/ as a draft.

I've moved this to the queue for mozillaignite, but you may also want to reach out to the Devs for this directly.
Assignee: mburns → nobody
Group: infra
Severity: critical → normal
Component: Server Operations: Web Operations → General
Product: mozilla.org → mozillaignite
QA Contact: cshields → ross
Version: other → unspecified
Just to clear up - login has always been done via browser/personaID so nothing has changed in that regard.

Likewise I've been able to create accounts, login to account and create stuff over on Ignite, as have a number of people I've had test it locally here in the UK.

Trying to think of things that would cause the problems I've got:

- unsupported browser (of course this doesn't explain being able to login with one email and not another)
- cookies turned off on computer (browserID needs cookies to be turned on but again this should be reported via the UI)
- browserID outage (there was one this morning, maybe there were more?)
- memcached on the VM potentially fallen over - :solarce can you confirm the status of memcached on the production ignite server?
- something changed with the browserID service and our implementation (am looking into that with :stomlinson at the moment but everything looks to be OK)

:solarce - do you see anything weird in the error logs that might highlight anything else?

As annoying as it is it could be an issue with just a small set of users.
I am not seeing anything in the error logs
(Reporter)

Comment 4

5 years ago
Hi folks,

Still having problems submitting.  I believe the problem is with Persona and certain browsers:  it's fine in Firefox but not in Safari.  Also, Chrome acts weird if you enter the wrong password with an account. 

Am I crazy?
Shane, please remove yourself/add others if you're interested in hearing more about this...
This does sound like something with the app is interacting with Persona
I'm trying to work out the exact use-case - after still being unable to reproduce yesterday. 

Not sure if this situation is with:

- brand new personaID's
- specific browsers

A bit of both...
:solarce can you please add this to the settings_local.py on the production box:

debug = dict(level=logging.DEBUG)

LOGGING = {
    'loggers': {
        'django_browserid': debug,
    },
}

It should provide us with more apache logging and hopefully highlight some errors - they do still seem to be occurring but as of yet I've been unable to work out why.

:solarce can you also let me know what we have for the following values in settings_local.py:

SITE_URL
SESSION_COOKIE_SECURE
SESSION_COOKIE_HTTPONLY

It's not like people can't login so it's unlikely these are set wrong but would be good to ensure.
Assignee: nobody → cturra
(Assignee)

Comment 9

5 years ago
(In reply to Ross Bruniges from comment #8)
> :solarce can you also let me know what we have for the following values in
> settings_local.py:
> 
> SITE_URL
> SESSION_COOKIE_SECURE
> SESSION_COOKIE_HTTPONLY

from the prod settings_local.py file...

  SITE_URL = 'https://mozillaignite.org'

  SESSION_COOKIE_SECURE = False
  SESSION_COOKIE_HTTPONLY = False
(Assignee)

Comment 10

5 years ago
i added the following parameters to the settings_local.py file...

  PROTOCOL = 'https://mozillaignite.org'
  DOMAIN = 'mozillaignite.org'


with this configuration, attempting to use browserid from www.mozillaignite.org would not work. as a result, i added a redirect so that all requests to www.mozillaignite.org would redirect to mozillaignite.org. after testing, this seems to have resolved the authentication issues.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
:cturra, thanks for adding those but I don't think they're needed anymore, SITE_URL trumps them both if it is defined.

Am wondering if you're able to have a look at the access logs to see if we're getting any traffic to www.mozillaignite.org? We've set the redirect up now but would be nice to try and work out if we've been getting un-redirected traffic to that, and if that's a likely culprit for the failed login reports that we have been getting...
You need to log in before you can comment on or make changes to this bug.