Country selection doesn't stick upon navigating pages

VERIFIED FIXED in 2012-08-16

Status

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: krupa.mozbugs, Assigned: andy+bugzilla)

Tracking

2012-08-16
Points:
---

Details

(Reporter)

Description

6 years ago
steps to reproduce:
1. Load https://marketplace-dev.allizom.org/
2. Tester has country = United States
3. Navigate to the details page
4. Change the country store to "Worldwide"
5. Navigate to the homepage


expected behavior:
The country store remains "Worldwide"

observed behavior:
The country selection reverts to "Worldwide"

screencast: http://screencast.com/t/Hmcwt5TE1MWK
(Reporter)

Comment 1

6 years ago
> observed behavior:
> The country selection reverts to "Worldwide"

Should be: The country selection reverts to "United States"
(Assignee)

Updated

6 years ago
Assignee: cvan → amckay
This happens in a new profile for me.

1) On Home. Region is United States.
2) Change region to Brazil in footer.
3) Navigate to an app detail page. Region is Brazil.
4) Click a different new page. Region is still Brazil.
5) Go back to Home. Region gets reset to United States.

It's worth noting that if you've changed your language to something other than English, then that change does stick.

Why this is happening/what is causing this is still very unknown to me.
(Assignee)

Comment 3

6 years ago
Tentative fix in. Prove it wrong @krupa!

https://github.com/mozilla/zamboni/commit/9311ad
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
All hail Andy.
(Reporter)

Comment 5

6 years ago
(In reply to Andy McKay [:andym] from comment #3)
> Tentative fix in. Prove it wrong @krupa!
> 
> https://github.com/mozilla/zamboni/commit/9311ad

Nah, you got it :)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.