Closed Bug 782492 Opened 7 years ago Closed 7 years ago

Accuweather - confirming selection of an item on the menu does nothing

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 781438

People

(Reporter: jsmith, Unassigned)

Details

Steps:

1. Go to http://m.accuweather.com/pt-br/south-america-weather?unit=c&phone=s 
2. Select Menu
3. Select an item other than menu and hit ok

Expected:

The site should load a different page based on the menu item selected.

Actual:

Nothing happens. If I compare this behavior to what is seen on FF Android with the FF OS user agent, I notice that this works fine. Sounds like a problem in the selection dialog on Firefox OS that likely happens after you click okay (event handling).
Basecamp nomination - this site in particular is under consideration to be a core third-party app, so the app better work on the phone.
blocking-basecamp: --- → ?
It would help if we had a reduced test case.  Suspicion is that we may not be firing onchange events (or not properly).

David, is creating a reduced test case something you could do?
Assignee: nobody → dclarke
Confirm the issue. 

Environment
-------------
1.6th August b2g, desktop build on Linux Mint Maya
2. latest gaia - e6eaa465ee2121230d651c84169ad33204ea0ca8
3. Selection of anything from the 'Menu' doesn't refresh the screen
4. Tested on latest Firefox (with the mobile URL) and when a dropdown from the Menu is selected, the page refreshes

Could be related to https://bugzilla.mozilla.org/show_bug.cgi?id=781438 and <select> is not available, per, this https://bugzilla.mozilla.org/show_bug.cgi?id=759511
Removing qawanted per comment 3. Duping on bug 781438.
Assignee: dclarke → nobody
Status: NEW → RESOLVED
blocking-basecamp: ? → ---
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 781438
You need to log in before you can comment on or make changes to this bug.