Last Comment Bug 782605 - Make nsNPAPIPluginInstance::SetCached infallible
: Make nsNPAPIPluginInstance::SetCached infallible
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: All All
: -- enhancement (vote)
: mozilla17
Assigned To: :Aryeh Gregor (working until September 2)
:
Mentors:
Depends on:
Blocks: nsresult-enum-class
  Show dependency treegraph
 
Reported: 2012-08-14 05:08 PDT by :Aryeh Gregor (working until September 2)
Modified: 2012-08-16 17:58 PDT (History)
1 user (show)
ayg: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (2.25 KB, patch)
2012-08-14 05:08 PDT, :Aryeh Gregor (working until September 2)
roc: review+
Details | Diff | Splinter Review

Description :Aryeh Gregor (working until September 2) 2012-08-14 05:08:18 PDT
Currently it purports to return nsresult, but always returns NS_OK.  This is a type error in _setvalue() in nsNPAPIPlugin.cpp, since it ostensibly returns NPError but in one place returns the result of SetCached().  So let's just make it officially infallible so it's not an issue.
Comment 1 :Aryeh Gregor (working until September 2) 2012-08-14 05:08:56 PDT
Created attachment 651704 [details] [diff] [review]
Patch

(This is the only caller.)
Comment 3 :Aryeh Gregor (working until September 2) 2012-08-16 05:59:19 PDT
Sorry, correct revision link: https://hg.mozilla.org/integration/mozilla-inbound/rev/66ae8a550cfc
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-08-16 17:58:04 PDT
https://hg.mozilla.org/mozilla-central/rev/66ae8a550cfc

Note You need to log in before you can comment on or make changes to this bug.