Intermittent mochitest-browser-chrome shutdown crash [@ libobjc.A.dylib@0xb390]

RESOLVED DUPLICATE of bug 735472

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 735472
7 years ago
7 years ago

People

(Reporter: emorley, Unassigned)

Tracking

({crash, intermittent-failure})

16 Branch
x86_64
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Rev4 MacOSX Lion 10.7 mozilla-aurora debug test mochitest-other on 2012-08-11 01:55:52 PDT for push 648e60750d53

slave: talos-r4-lion-031

https://tbpl.mozilla.org/php/getParsedLog.php?id=14313045&tree=Mozilla-Aurora

{
###!!! ASSERTION: stylesheet not found: 'Not Reached', file ../../../../content/base/src/nsDocument.cpp, line 3512
mozilla::scache::PathifyURI(nsIURI*, nsACString_internal&)+0x0064EBDF [/Users/cltbld/talos-slave/test/build/FirefoxAuroraDebug.app/Contents/MacOS/XUL +0x008CF6EF]
mozilla::scache::PathifyURI(nsIURI*, nsACString_internal&)+0x0064F77B [/Users/cltbld/talos-slave/test/build/FirefoxAuroraDebug.app/Contents/MacOS/XUL +0x008D028B]
mozilla::scache::PathifyURI(nsIURI*, nsACString_internal&)+0x009093B3 [/Users/cltbld/talos-slave/test/build/FirefoxAuroraDebug.app/Contents/MacOS/XUL +0x00B89EC3]
mozilla::scache::PathifyURI(nsIURI*, nsACString_internal&)+0x005A303F [/Users/cltbld/talos-slave/test/build/FirefoxAuroraDebug.app/Contents/MacOS/XUL +0x00823B4F]
mozilla::scache::PathifyURI(nsIURI*, nsACString_internal&)+0x009FA8C3 [/Users/cltbld/talos-slave/test/build/FirefoxAuroraDebug.app/Contents/MacOS/XUL +0x00C7B3D3]
NS_CycleCollectorSuspect2_P+0x00001503 [/Users/cltbld/talos-slave/test/build/FirefoxAuroraDebug.app/Contents/MacOS/XUL +0x01E54CA3]
NS_CycleCollectorSuspect2_P+0x000016E3 [/Users/cltbld/talos-slave/test/build/FirefoxAuroraDebug.app/Contents/MacOS/XUL +0x01E54E83]
NS_CycleCollectorSuspect2_P+0x0000194B [/Users/cltbld/talos-slave/test/build/FirefoxAuroraDebug.app/Contents/MacOS/XUL +0x01E550EB]
NS_CycleCollectorSuspect2_P+0x0000234F [/Users/cltbld/talos-slave/test/build/FirefoxAuroraDebug.app/Contents/MacOS/XUL +0x01E55AEF]
NS_CycleCollectorSuspect2_P+0x00002620 [/Users/cltbld/talos-slave/test/build/FirefoxAuroraDebug.app/Contents/MacOS/XUL +0x01E55DC0]
NS_InitXPCOM+0x000005EB [/Users/cltbld/talos-slave/test/build/FirefoxAuroraDebug.app/Contents/MacOS/XUL +0x01DC7D6B]
XRE_InitOmnijar+0x00000D43 [/Users/cltbld/talos-slave/test/build/FirefoxAuroraDebug.app/Contents/MacOS/XUL +0x000062F3]
XRE_InitCommandLine+0x00003133 [/Users/cltbld/talos-slave/test/build/FirefoxAuroraDebug.app/Contents/MacOS/XUL +0x00015B83]
XRE_main+0x0000010A [/Users/cltbld/talos-slave/test/build/FirefoxAuroraDebug.app/Contents/MacOS/XUL +0x0001612A]
start+0x00000B8C [/Users/cltbld/talos-slave/test/build/FirefoxAuroraDebug.app/Contents/MacOS/firefox-bin +0x00001C6C]
--DOMWINDOW == 7 (0x1087f61e0) [serial = 1] [outer = 0x0] [url = chrome://browser/content/browser.xul]
--DOMWINDOW == 6 (0x10a1bae20) [serial = 3] [outer = 0x0] [url = chrome://browser/content/hiddenWindow.xul]
--DOMWINDOW == 5 (0x113645fe0) [serial = 12] [outer = 0x0] [url = chrome://mochikit/content/browser-harness.xul]
--DOMWINDOW == 4 (0x13b97e670) [serial = 660] [outer = 0x0] [url = chrome://browser/content/tabview.html]
--DOMWINDOW == 3 (0x13c3d83b0) [serial = 661] [outer = 0x0] [url = chrome://browser/content/tabview.html]
--DOMWINDOW == 2 (0x113642dc0) [serial = 13] [outer = 0x0] [url = about:blank]
WARNING: not an nsIRDFRemoteDataSource: 'remote != nsnull', file ../../../../rdf/datasource/src/nsLocalStore.cpp, line 279
--DOMWINDOW == 1 (0x10a1be160) [serial = 4] [outer = 0x0] [url = chrome://browser/content/hiddenWindow.xul]
WARNING: not an nsIRDFRemoteDataSource: 'remote != nsnull', file ../../../../rdf/datasource/src/nsLocalStore.cpp, line 279
--DOMWINDOW == 0 (0x10a1054f0) [serial = 2] [outer = 0x0] [url = about:blank]
WARNING: not an nsIRDFRemoteDataSource: 'remote != nsnull', file ../../../../rdf/datasource/src/nsLocalStore.cpp, line 279
TEST-UNEXPECTED-FAIL | Shutdown | Exited with code 1 during test run
INFO | automation.py | Application ran for: 0:54:10.159413
INFO | automation.py | Reading PID log: /var/folders/qd/srwd5f710sj0fcl9z464lkj00000gn/T/tmpZ_Zd8Fpidlog
Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-aurora-macosx64-debug/1344668084/firefox-16.0a2.en-US.mac64.crashreporter-symbols.zip
PROCESS-CRASH | Shutdown | application crashed (minidump found)
Crash dump filename: /var/folders/qd/srwd5f710sj0fcl9z464lkj00000gn/T/tmpWQhaaY/minidumps/62D5A973-C0F2-48ED-B3DD-8E8CE3F14A33.dmp
Operating system: Mac OS X
                  10.7.2 11C74
CPU: amd64
     family 6 model 23 stepping 10
     2 CPUs

Crash reason:  EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
Crash address: 0x74a873a8

Thread 0 (crashed)
 0  libobjc.A.dylib + 0xb390
    rbx = 0x3f200fb0   r12 = 0x04028d40   r13 = 0x5fbfeb90   r14 = 0x3f201a30
    r15 = 0x3f2010f0   rip = 0x88834390   rsp = 0x5fbfe5a8   rbp = 0x5fbfe5f0
    Found by: given as instruction pointer in context
 1  AppKit + 0x242c35
    rip = 0x86211c36   rsp = 0x5fbfe5b0
    Found by: stack scanning
 2  libobjc.A.dylib + 0xd417
    rip = 0x88836418   rsp = 0x5fbfe5c0
    Found by: stack scanning
 3  XUL!-[BaseWindow dealloc] [nsCocoaWindow.mm : 2269 + 0x1e]
    rip = 0x029f1253   rsp = 0x5fbfe600
    Found by: stack scanning
 4  AppKit + 0x4266b
    rip = 0x8601166c   rsp = 0x5fbfe630
    Found by: stack scanning
 5  libobjc.A.dylib + 0xed52
    rip = 0x88837d53   rsp = 0x5fbfe660
    Found by: stack scanning
 6  CoreFoundation + 0x316e5
    rip = 0x855fb6e6   rsp = 0x5fbfe680
    Found by: stack scanning
 7  libobjc.A.dylib + 0xf03b
    rip = 0x8883803c   rsp = 0x5fbfe6b0
    Found by: stack scanning
 8  libsystem_c.dylib + 0x6b02e
    rip = 0x896fa02f   rsp = 0x5fbfe720
    Found by: stack scanning
 9  libsystem_c.dylib + 0x6b02e
    rip = 0x896fa02f   rsp = 0x5fbfe790
    Found by: stack scanning
10  libsystem_c.dylib + 0x6a710
    rip = 0x896f9711   rsp = 0x5fbfe7b0
    Found by: stack scanning
11  libsystem_c.dylib + 0x4d46f
    rip = 0x896dc470   rsp = 0x5fbfe7e0
    Found by: stack scanning
12  AppKit + 0x883a9f
    rip = 0x86852aa0   rsp = 0x5fbfe850
}

Further back in the log there was also:
{
###!!! ASSERTION: Profile change cancellation.: 'Error', file ../../../toolkit/xre/nsXREDirProvider.cpp, line 817
XRE_StartupTimelineRecord+0x0007E03B [/Users/cltbld/talos-slave/test/build/FirefoxAuroraDebug.app/Contents/MacOS/XUL +0x01725A4B]
XRE_StartupTimelineRecord+0x000821DB [/Users/cltbld/talos-slave/test/build/FirefoxAuroraDebug.app/Contents/MacOS/XUL +0x01729BEB]
mozilla::services::_external_GetIOService()+0x0001E66A [/Users/cltbld/talos-slave/test/build/FirefoxAuroraDebug.app/Contents/MacOS/XUL +0x01DE7F7A]
mozilla::services::_external_GetIOService()+0x0001F20D [/Users/cltbld/talos-slave/test/build/FirefoxAuroraDebug.app/Contents/MacOS/XUL +0x01DE8B1D]
XRE_main+0x00001719 [/Users/cltbld/talos-slave/test/build/FirefoxAuroraDebug.app/Contents/MacOS/XUL +0x00017739]
XRE_InitOmnijar+0x00000D35 [/Users/cltbld/talos-slave/test/build/FirefoxAuroraDebug.app/Contents/MacOS/XUL +0x000062E5]
XRE_InitCommandLine+0x00003133 [/Users/cltbld/talos-slave/test/build/FirefoxAuroraDebug.app/Contents/MacOS/XUL +0x00015B83]
XRE_main+0x0000010A [/Users/cltbld/talos-slave/test/build/FirefoxAuroraDebug.app/Contents/MacOS/XUL +0x0001612A]
start+0x00000B8C [/Users/cltbld/talos-slave/test/build/FirefoxAuroraDebug.app/Contents/MacOS/firefox-bin +0x00001C6C]
}

...see also bug 715137.
The stylesheet not found assertion happens all the time and isn't relevant.
Thank you :-)
Crash Signature: [@ libobjc.A.dylib@0xb390]
Keywords: assertioncrash
Summary: Intermittent Shutdown | Exited with code 1 during test run (after: "ASSERTION: stylesheet not found: 'Not Reached', file ../../../../content/base/src/nsDocument.cpp, line 3512") → Intermittent mochitest-browser-chrome shutdown crash [@ libobjc.A.dylib@0xb390]
Unless it happens on another, non-defective slave, the best bet here is [badslave].
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: talos-r4-lion-031
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.