Closed Bug 782632 Opened 7 years ago Closed 7 years ago

Intermittent crash in browser_styleinspector_bug_689759_no_results_placeholder.js [@ js::gc::finalize<JSObject>]

Categories

(Core :: JavaScript Engine, defect, critical)

x86_64
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 735472

People

(Reporter: emorley, Unassigned)

References

Details

(Keywords: crash, intermittent-failure)

Crash Data

Rev4 MacOSX Lion 10.7 mozilla-inbound opt test mochitest-other on 2012-08-14 03:57:09 PDT for push 2d595c62abcb

slave: talos-r4-lion-031

https://tbpl.mozilla.org/php/getParsedLog.php?id=14366900&tree=Mozilla-Inbound

{
TEST-START | chrome://mochitests/content/browser/browser/devtools/styleinspector/test/browser_styleinspector_bug_689759_no_results_placeholder.js
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/styleinspector/test/browser_styleinspector_bug_689759_no_results_placeholder.js | Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "data:text/html,no%20results%20placeholder%20test" line: 0}]
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/styleinspector/test/browser_styleinspector_bug_689759_no_results_placeholder.js | captain, we have the matches span
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/styleinspector/test/browser_styleinspector_bug_689759_no_results_placeholder.js | style inspector node matches the selected node
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/styleinspector/test/browser_styleinspector_bug_689759_no_results_placeholder.js | cssLogic node matches the cssHtmlTree node
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/styleinspector/test/browser_styleinspector_bug_689759_no_results_placeholder.js | setting filter text to "xxxxx"
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/styleinspector/test/browser_styleinspector_bug_689759_no_results_placeholder.js | SI_checkPlaceholderVisible called
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/styleinspector/test/browser_styleinspector_bug_689759_no_results_placeholder.js | placeholder is visible
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/styleinspector/test/browser_styleinspector_bug_689759_no_results_placeholder.js | clearing filter text
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/styleinspector/test/browser_styleinspector_bug_689759_no_results_placeholder.js | Exited with code 1 during test run
INFO | automation.py | Application ran for: 0:12:53.548298
INFO | automation.py | Reading PID log: /var/folders/qd/srwd5f710sj0fcl9z464lkj00000gn/T/tmppLxvIepidlog
Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-macosx64/1344938383/firefox-17.0a1.en-US.mac.crashreporter-symbols.zip
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/styleinspector/test/browser_styleinspector_bug_689759_no_results_placeholder.js | application crashed (minidump found)
Crash dump filename: /var/folders/qd/srwd5f710sj0fcl9z464lkj00000gn/T/tmpUSq0mA/minidumps/EA85FBBD-722C-4957-A0D9-62D7F48D734B.dmp
Operating system: Mac OS X
                  10.7.2 11C74
CPU: amd64
     family 6 model 23 stepping 10
     2 CPUs

Crash reason:  EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
Crash address: 0x0

Thread 0 (crashed)
 0  XUL!js::gc::finalize<JSObject> [jsscope.h : 603 + 0x0]
    rbx = 0x5aba1340   r12 = 0x00000030   r13 = 0x5aba1430   r14 = 0x5aba13d0
    r15 = 0x5aba1040   rip = 0x02447b87   rsp = 0x5fbfcfe0   rbp = 0x5fbfd040
    Found by: given as instruction pointer in context
 1  XUL!PRMJ_Now [prmjtime.cpp : 279 + 0x4]
    rip = 0x02520a03   rsp = 0x5fbfd010
    Found by: stack scanning
 2  XUL!js::gc::ArenaLists::queueObjectsForSweep [jsgc.cpp : 383 + 0x14]
    rip = 0x0243db49   rsp = 0x5fbfd050
    Found by: stack scanning
 3  XUL!IncrementalCollectSlice [jsgc.cpp : 3542 + 0xb]
    rip = 0x024441ac   rsp = 0x5fbfd090
    Found by: stack scanning
 4  GeForceGLDriver + 0x18
    rip = 0x00000019   rsp = 0x5fbfd0d8
    Found by: stack scanning
 5  libsystem_c.dylib + 0x4d46f
    rip = 0x8e32a470   rsp = 0x5fbfd0e0
    Found by: stack scanning
 6  libsystem_c.dylib + 0x3e1ef
    rip = 0x8e31b1f0   rsp = 0x5fbfd160
    Found by: stack scanning
 7  XUL!PRMJ_Now [prmjtime.cpp : 279 + 0x4]
    rip = 0x02520a03   rsp = 0x5fbfd190
    Found by: stack scanning
 8  XUL!GCCycle [jsgc.cpp : 4119 + 0x10]
    rip = 0x02442bef   rsp = 0x5fbfd1d0
    Found by: stack scanning
 9  XUL!Collect [jsgc.cpp : 4227 + 0x14]
    rip = 0x0244041c   rsp = 0x5fbfd220
    Found by: stack scanning
10  XUL!nsJSContext::GarbageCollectNow [nsJSEnvironment.cpp : 2952 + 0xa]
    rip = 0x016701d1   rsp = 0x5fbfd270
    Found by: stack scanning
11  XUL + 0x67561f
    rip = 0x01675620   rsp = 0x5fbfd298
    Found by: stack scanning
12  XUL!nsTimerImpl::Fire [nsTimerImpl.cpp : 473 + 0x9]
    rip = 0x01f490ff   rsp = 0x5fbfd2b0
}
Poor old 031, wandering around the nursing home drooling and flashing the employees, and every so often tripping over its own feet.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: talos-r4-lion-031
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.