Installer erases parts of desktop (window manager port)

VERIFIED FIXED in mozilla0.9.1

Status

SeaMonkey
Installer
P2
critical
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: Mike Pinkerton (not reading bugmail), Assigned: Samir Gehani)

Tracking

Trunk
mozilla0.9.1
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Fix in hand)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Both the mozilla and commercial installers erase parts of the desktop when they 
finish downloading the XPIs and begin installing. The attached image shows the 
problem.
(Reporter)

Comment 1

17 years ago
Created attachment 32693 [details]
desktop being erased
(Reporter)

Updated

17 years ago
Keywords: nsbeta1, nsmac2, regression
Summary: Installer draws to window manager port → Installer erases parts of desktop (window manager port)

Comment 2

17 years ago
you scared me for a sec there, d00d! I thought you were talking about the 
windows platform.  All I saw was 'window' :)

reassigning to samir.
Assignee: ssu → sgehani
(Assignee)

Comment 3

17 years ago
Oops, looks like GetPort/SetPort problems.  Setting priority to P2 in line with
severity set to critical and attempting to get it done by mozilla0.9.1.
Status: NEW → ASSIGNED
Priority: -- → P2
Target Milestone: --- → mozilla0.9.1

Updated

17 years ago
QA Contact: gemal → gbush

Updated

17 years ago
Keywords: nsbeta1, nsmac2, regression → nsbeta1+
(Assignee)

Comment 4

17 years ago
Created attachment 33815 [details] [diff] [review]
GetPort/SetPort calls so we erase rects in our normalized coordinates rather than global coordinates.
(Assignee)

Comment 5

17 years ago
Simon, please review.  Thanks.
Whiteboard: Fix in hand
(Reporter)

Comment 6

17 years ago
looks ok to me. don't we have a nice stackbased class to do this? 
(Assignee)

Comment 7

17 years ago
The installer code is in C.  Assuming r=pinkerton.  Thanks pink!
(Reporter)

Comment 8

17 years ago
yeah, sorry. r=pink
(Assignee)

Comment 9

17 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 10

17 years ago
Get/SetPorts are always good. Do we need them elsewhere?

sr=sfraser

Comment 11

17 years ago
verified code fix
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.