Last Comment Bug 782672 - Block-list old Versions of silverlight on Mac
: Block-list old Versions of silverlight on Mac
Status: RESOLVED FIXED
:
Product: Toolkit
Classification: Components
Component: Blocklisting (show other bugs)
: unspecified
: All Mac OS X
: -- major (vote)
: ---
Assigned To: Jorge Villalobos [:jorgev]
: juan becerra [:juanb]
Mentors:
Depends on:
Blocks: 753251 769398
  Show dependency treegraph
 
Reported: 2012-08-14 09:07 PDT by Tyler Downer [:Tyler]
Modified: 2016-03-07 15:30 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Tyler Downer [:Tyler] 2012-08-14 09:07:10 PDT
Silverlight on Mac has been killing us recently, especially the older 4.X versions (Currently it is at 5.1.10411.0). The older versions have resulted in several bugs, such as bug 753251, as well as bug 769398 comment 19. We should investigate blocking at least the 4.x versions in firefox to help alleviate the crashes (the netflix issue is still up in the air on if updating will alleviate the problem or not).
Comment 1 Jorge Villalobos [:jorgev] 2012-08-14 14:19:38 PDT
Do we have any numbers on how serious the problem is for the different versions? Is it mostly a problem in the 4.* branch, some of the 5.* branch, or distributed among all versions including the latest one?
Comment 2 Jorge Villalobos [:jorgev] 2012-08-14 14:21:24 PDT
Also, can you tell me what the "(all?)" is for? Is this also a problem in other platforms, or was that referring to all versions?
Comment 3 Tyler Downer [:Tyler] 2012-08-14 14:25:23 PDT
I can take a look tomorrow and pull some of the affected versions from users we've been working 1:1 with. Going off what I have right now, 4.0.51204.0 and 4.0.50401.0 are both problematic and causing crashing in Hotmail on Mac. These are fixed by upgrading to the latest version. 

I put all as I'm not sure if we should confine this to just Mac, or all Platforms. I want to take a look this week and see if there are also issues recently involving Silverlight on windows as well. At this time I don't believe there are as large of issues on Windows however, so I don't think that is needed at this time (that can always change later).
Comment 4 Tyler Downer [:Tyler] 2012-08-15 06:48:20 PDT
Problem causing versions:
4.0.51204.0
4.0.50401.0
4.0.60129.0
All these users reported that the hotmail issue was fixed upon upgrading silverlight.
This seems to be spread across the whole 4.x branch. We should just block anything under the 5.1 branch (current).
Comment 5 Jorge Villalobos [:jorgev] 2012-08-16 10:14:37 PDT
Since we cover Silverlight in the plugincheck page, we can use the lowest block level, which just urges users to update to the latest version and directs them to the plugincheck page. The notification will appear every time they visit a page that uses Silverlight.

We need to eventually remove the block, since the message can't be dismissed (in some cases?) and it can become extremely annoying, and it's possible some users can't update for whatever reason. After evaluating the success of this block we can consider doing a softblock next if necessary.
Comment 6 Tyler Downer [:Tyler] 2012-08-16 14:20:02 PDT
Jorge,
The one problem I can see, and correct me if I'm wrong, but one of the big crashes in the older versions of silverlight is a crash on webpages such as Hotmail. Some users are getting this crash as soon as they navigate to the website. My only worry would be that they would never see this update prompt. but we can launch this, watch the crash stats, and if they don't go down significantly I'd urge a Softblock. My only concern.
Comment 7 Jorge Villalobos [:jorgev] 2012-08-16 14:58:20 PDT
Ah, I wasn't aware of this. A softblock is more appropriate then.
Comment 8 Jorge Villalobos [:jorgev] 2012-08-17 16:02:26 PDT
The block is now staged here:
https://addons-dev.allizom.org/en-US/firefox/blocked/p123

The version range has been tentatively set from version 0 to 5.0.9, so try to cover all old versions up to the 5.0.* branch. I'll try to contact Microsoft to give them a heads up and see if the version range is correct.
Comment 9 juan becerra [:juanb] 2012-08-21 17:14:47 PDT
I tried version 4.0.60310.0 of Silverlight and that got blocked, but version 5.0.61118.0 does not seem to get blocked using the usual procedure to test.

Version 5.1.x does not get blocked as expected.
Comment 10 Jorge Villalobos [:jorgev] 2012-08-22 09:07:49 PDT
(In reply to juan becerra [:juanb] from comment #9)
> I tried version 4.0.60310.0 of Silverlight and that got blocked, but version
> 5.0.61118.0 does not seem to get blocked using the usual procedure to test.

Yes, 5.0.61118.0 > 5.0.9. I'll adjust the max version to 5.0.99999 when I push it to prod.
 
> Version 5.1.x does not get blocked as expected.

Thanks!
Comment 12 erpman1 2012-08-23 12:02:50 PDT
what about Silverlight version 4.1.10329 mentioned in Microsoft Support KB article 2690729:
http://support.microsoft.com/kb/2690729/en-us
this is the most recent security update for Silverlight 4.x.

will that specific version of Silverlight for Mac be blocked or not?
Comment 13 Jorge Villalobos [:jorgev] 2012-08-23 12:37:53 PDT
That version is included in the block. Is there any reason you can't upgrade to Silverlight 5?

Note You need to log in before you can comment on or make changes to this bug.