WARNING: No outer window available!: file dom/base/nsGlobalWindow.cpp, line 9152

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
7 years ago
2 months ago

People

(Reporter: mats, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

7 years ago
WARNING: No outer window available!: file dom/base/nsGlobalWindow.cpp, line 9152

While running the crashtest suite in a mozilla-inbound Linux64 build
I get 1786 instances of this warning (there are 2098 tests).
That seems a lot more than usual.
Depends on: 630242
For mochitest-other logs, I'm seeing roughly:

Windows: 60k occurrences (!)
Linux: 35k occurrences
Mac: 30k occurrences

Since the warning is ~100 characters (more on Windows, less on other platforms), these warnings are taking ~10-15% of the space of mochitest-other logs.
I'm not sure if this bug is still valid or if I'm even testing this right.

I checked out mozilla-inbound and built it on Fedora 21 64-bit successfully. Then I ran "./mach crashtest > crashtest.log", followed by "cat crashtest.log | grep WARNING". This printed out 30 warnings but none of them were "WARNING: No outer window available!: file dom/base/nsGlobalWindow.cpp, line 9152".

Am I doing this wrong?
Flags: needinfo?(mats)
Reporter

Comment 3

4 years ago
Looking at the patch in bug 630242, I think that's what fixed it.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(mats)
Resolution: --- → FIXED
(In reply to Mats Palmgren (:mats) from comment #3)
> Looking at the patch in bug 630242, I think that's what fixed it.

Thanks for checking, Mats.
Component: DOM → DOM: Core & HTML
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.