Command + Backspace not working

RESOLVED DUPLICATE of bug 1357933

Status

()

Firefox
Keyboard Navigation
RESOLVED DUPLICATE of bug 1357933
6 years ago
3 months ago

People

(Reporter: robbie.bykowski, Unassigned)

Tracking

17 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20120814030521

Steps to reproduce:

For any text input field whether its in Firefox UI or a webpage, command + backspace does not work.


Actual results:

Nothing


Expected results:

On the line of the cursor, everything before the cursor should be deleted

Comment 1

6 years ago
In Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/17.0 Firefox/17.0, Ctrl+Backspace deletes the last word for me.  According to bug 246237 and its duplicates, that’s the expected behaviour on Windows, too.
(Reporter)

Comment 2

6 years ago
command is not the same as ctrl.

The standard behaviour on a mac is
command + backspace : deletes to the beginning of the line
alt + backspace : deletes to the beginning of the boundary of a word
ctrl + backspace : does the same as backspace

only alt + backspace works
I see you're reporting this under 10.8. Did this work for previous versions of Mac or Firefox?
Component: Untriaged → Keyboard Navigation

Comment 4

6 years ago
This has never worked in any version of firefox I have used since I became a regular user in June this year. I have tried the latest builds of Beta, Aurora and Nightly.

Comment 5

5 years ago
I also see this issue, and have seen it forever.  I'm sure it has to do with the non-system UI controls.

Comment 6

5 years ago
I have the same issue with Firefox 22.0 (Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:22.0) Gecko/20100101 Firefox/22.0).

Command + backspace to delete the whole input field (whether inside a web form or the location url) is a normal behaviour for any OSX application.  I think this is an urgent issue to fix.

Comment 7

5 years ago
I too am having this issue with Firefox 24.0 on OS X 10.8.5.

It's something I've always experienced on Firefox for Mac, and given I use the CMD+Backspace shortcut all of the time in almost every application I use, it is a really annoying issue for me.

Comment 8

5 years ago
I am also experiencing this issue with FF 24.0 on OSX 10.7.5.

Comment 9

5 years ago
This is now working again with the update to FF 25.0 on 10.7.5!

Comment 10

4 years ago
(In reply to Rodrigo Ayala from comment #6)
> Command + backspace to delete the whole input field (whether inside a web
> form or the location url) is a normal behaviour for any OSX application.  I
> think this is an urgent issue to fix.

I disagree. The normal behaviour is to delete from the cursor to the beginning of the line, but now it works the same way you say, it deletes everything, which is confusing.

Comment 11

3 years ago
Can confirm that this is still an issue at Firefox 40.0 from the beta channel, on OS X 10.10.4.

Updated

3 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 12

3 months ago
The issue here seems to be what is described in comment #10, so I'm duping this to 1357933
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1357933
You need to log in before you can comment on or make changes to this bug.