No hardware acceleration on 32-bit Firefox in Mac OS Mountain Lion

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: fxcoudert, Unassigned)

Tracking

17 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20120813150150

Steps to reproduce:

Running Firefox Nightly on Mac OS 10.8.0 (Mountain Lion) in 32-bit mode, hardware acceleration is not supported. The relevant section of about:support says:

Graphics
Vendor ID: 0x10de
Device ID: 0x fd5
WebGL Renderer: NVIDIA Corporation -- NVIDIA GeForce GT 650M OpenGL Engine -- 2.1 NVIDIA-8.0.51
GPU Accelerated Windows: 0
Azure Canvas Backend: quartz
Azure Fallback Canvas Backend: none
Azure Content Backend: none

even though I have "Use hardware acceleration when available" checked in my Firefox preferences. On the contrary, the about:support window in 64-bit mode says:

Graphics
Vendor ID: 0x10de
Device ID: 0x fd5
WebGL Renderer: NVIDIA Corporation -- NVIDIA GeForce GT 650M OpenGL Engine -- 2.1 NVIDIA-8.0.51
GPU Accelerated Windows: 1/1 OpenGL
AzureCanvasBackend: quartz
AzureFallbackCanvasBackend: none
AzureContentBackend: none
We explicitly don't support OpenGL in 32-bit mode, because 32-bit mode supports QuickDraw plugins that don't draw correctly with hardware acceleration.

Sorry!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Component: Untriaged → Graphics
Product: Firefox → Core
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.