Last Comment Bug 782739 - mouse wheel zoom is lost after tab switch
: mouse wheel zoom is lost after tab switch
Status: RESOLVED FIXED
: regression
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: Trunk
: x86_64 All
: -- normal (vote)
: Firefox 17
Assigned To: Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured)
:
Mentors:
Depends on:
Blocks: 719320 784503
  Show dependency treegraph
 
Reported: 2012-08-14 12:00 PDT by Timothy Nikkel (:tnikkel)
Modified: 2012-08-21 14:25 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.97 KB, patch)
2012-08-14 19:30 PDT, Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured)
no flags Details | Diff | Review
Patch (6.70 KB, patch)
2012-08-15 02:43 PDT, Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured)
bugs: review+
dao+bmo: review+
Details | Diff | Review

Description Timothy Nikkel (:tnikkel) 2012-08-14 12:00:34 PDT
Hold ctrl and rotate the mouse wheel to change zoom. Change tabs. Return on the original tab. The zoom change is lost for me.

I bisected this down to the patches for bug 719320.
Comment 1 Alice0775 White 2012-08-14 12:45:19 PDT
I can reproduce the problem on Windows7 too.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120814030521
Comment 2 Alice0775 White 2012-08-14 13:56:59 PDT
In http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser-fullZoom.js#89 ,
It is necessary to adapt preferences name to the latest.
Comment 3 Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured) 2012-08-14 18:20:15 PDT
(In reply to Alice0775 White from comment #2)
> In
> http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser-
> fullZoom.js#89 ,
> It is necessary to adapt preferences name to the latest.

Ah, failed to catch such code by searching "mousewheel.".
Comment 4 Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured) 2012-08-14 19:30:26 PDT
Created attachment 651976 [details] [diff] [review]
Patch

https://tbpl.mozilla.org/?tree=Try&usebuildbot=1&rev=7aa024811555
Comment 5 Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured) 2012-08-15 02:43:36 PDT
Created attachment 652049 [details] [diff] [review]
Patch

Hmm, this feature doesn't work with SpecialPowers.setFullZoom(). I think that when zoom in or out is performed, Gecko should dispatch a custom event and browser should listen it. But this patch is enough for now.
Comment 6 Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured) 2012-08-15 08:52:20 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/d0ca290ec99c
Comment 7 Ryan VanderMeulen [:RyanVM] 2012-08-15 18:46:10 PDT
https://hg.mozilla.org/mozilla-central/rev/d0ca290ec99c

Note You need to log in before you can comment on or make changes to this bug.