Implement per-tab private browsing

RESOLVED DUPLICATE of bug 648517

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 648517
6 years ago
9 months ago

People

(Reporter: evold, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

per-window private browsing is introduced by bug 463027, but I think that most users won't want to manage multiple windows, and use tabs instead, so per-tab private browsing seems to make more sense to me.
Severity: normal → enhancement

Comment 1

6 years ago
We have talked about this before very extensively.  We don't have a good solution on how we would expose the UI in a sensible way.  We can use visual cues to make an entire window a different color, but doing that on a per-tab basis would look very weird.

The new PB API gives extension developers the ability to build extensions which would expose per-tab PB, and we might consider doing that if someone comes up with a good idea, but for now I am going to wontfix this.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
(In reply to Ehsan Akhgari [:ehsan] from comment #1)
> We have talked about this before very extensively.  We don't have a good
> solution on how we would expose the UI in a sensible way.  We can use visual
> cues to make an entire window a different color, but doing that on a per-tab
> basis would look very weird.

Using the context menu, along with coloring the tab different seems reasonable to me too.

> The new PB API gives extension developers the ability to build extensions
> which would expose per-tab PB, and we might consider doing that if someone
> comes up with a good idea, but for now I am going to wontfix this.

This sound to me like we could/should support per-tab private browsing in the addon-sdk.

Comment 3

6 years ago
(In reply to comment #2)
> (In reply to Ehsan Akhgari [:ehsan] from comment #1)
> > We have talked about this before very extensively.  We don't have a good
> > solution on how we would expose the UI in a sensible way.  We can use visual
> > cues to make an entire window a different color, but doing that on a per-tab
> > basis would look very weird.
> 
> Using the context menu, along with coloring the tab different seems reasonable
> to me too.

How would using the context menu help?  Coloring tabs differently is definitely possible but would be somewhat controversial, and IIRC the UX team has no interest in doing that.

> > The new PB API gives extension developers the ability to build extensions
> > which would expose per-tab PB, and we might consider doing that if someone
> > comes up with a good idea, but for now I am going to wontfix this.
> 
> This sound to me like we could/should support per-tab private browsing in the
> addon-sdk.

Depends on what you mean by support.  A lot of the Firefox front-end code makes assumptions that all of the tabs in the same window follow the mode of the window itself, so all of that code would need to be modified if you want to to get this to work correctly.

But I thought that the intention of the add-on sdk is to expose APIs which make it easy to modify Firefox, not to modify Firefox itself.  It would be very weird if an add-on which uses the SDK provided PB APIs gets a different PB experience than what is already happening in the product without that add-on.

Updated

9 months ago
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 648517
You need to log in before you can comment on or make changes to this bug.